Trees on the level

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics. 

This problem involves building and traversing binary trees. 
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes. 

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1. 

For example, a level order traversal of the tree 

 
is: 5, 4, 8, 11, 13, 4, 7, 2, 1. 

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once. 
 

Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses. 

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file. 
 

Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete

题意:按要求建立二叉树,然后从上到下,从左到右输出。

思路:如果用数组的话,线性结构保存,数组太大,开不出来,所以不行。这里需要采用动态结构。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<new>
#include<queue>
#define maxn 100000
using namespace std;
//节点类型
struct Node{
    int v;             //节点值
    bool have_value;    //标记是否被赋值过
    Node *left,*right;
    Node():have_value(false),left(NULL),right(NULL){};  //构造函数
};
Node* root;        //定义根节点
char s[maxn];
bool failed=false;

void addnode(int v,char *s){
    int n=strlen(s);
    Node* u=root;        //从根节点往下走
    for(int i=0;i<n;i++){
        if(s[i]=='L'){
            if(u->left==NULL)u->left=new Node(); //节点不存在,建立新节点
            u=u->left;      //往左走
        }
        else if(s[i]=='R'){
            if(u->right==NULL)u->right=new Node();
            u=u->right;    //往右走
        }
    }
    if(u->have_value) failed=true;  //已经赋值过,说明输入错误
    u->v=v;
    u->have_value=true;      //标记
}

bool read_input()  
{
    failed=false;
    root=new Node();    //创建根节点
    for(;;){
        if(scanf("%s",s)!=1) return false;  //整个输入结束
        if(!strcmp(s,"()"))break;   //读到结束标志,退出循环
        int v;
        sscanf(&s[1],"%d",&v);      //读入节点值
        addnode(v,strchr(s,',')+1);  //插入节点
    }
    return true;
}

bool bfs(vector<int>& ans){
    queue<Node*> q;
    ans.clear();
    q.push(root);
    while(!q.empty()){
        Node *u=q.front();
        q.pop();
        if(!u->have_value) return false;  //有节点没有赋值过,输入有误
        ans.push_back(u->v);
        if(u->left!=NULL) q.push(u->left);
        if(u->right!=NULL) q.push(u->right);
    }
    return true;
}

int main()
{
    while(read_input())  //输入
     {
        if(failed)
            printf("not complete\n");
        else{
            vector<int>ans;
            if(bfs(ans)){
                vector<int>::iterator it;
                for(it=ans.begin();it!=ans.end();it++){
                    if(it!=ans.begin())
                        printf(" ");
                    printf("%d",*it);
                }
                printf("\n");
            }
            else printf("not complete\n");
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值