PAT(甲级)1016. Phone Bills (25)

本文介绍了一个基于电话记录和费率结构实现的电话计费系统。该系统能够处理大量的电话记录,通过匹配开始和结束记录来计算每个用户的通话时间和费用,并最终生成详细的月度账单。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Phone Bills (25)

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word “on-line” or “off-line”.

For each test case, all dates will be within a single month. Each “on-line” record is paired with the chronologically next record for the same customer provided it is an “off-line” record. Any “on-line” records that are not paired with an “off-line” record are ignored, as are “off-line” records not paired with an “on-line” record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.
Sample Input:10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:CYJJ 01
01:05:59 01:07:00 61 12.10Totalamount:  12.10
CYLL 01
01:06:01 01:08:03 122 24.4028:15:4128:16:0524  3.85
Total amount: 28.25aaa0102:00:0104:23:594318  638.80
Total amount: $638.80

题目大意:给出n个电话记录和24个小时每个小时单位时间花费 保证每个人的电话记录在一个月内 找出相互匹配的记录 计算通话时间和花费 保证至少存在一个匹配的通话记录
分析:模拟 写了两遍 第一遍15分 但是没找到错。。。。然后从头换思路写 看到25分的一瞬间很惊喜 不敢相信。。。。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#define maxn 1010
using namespace std;
int n,sal[24];
struct node{
    char name[30];
    int mm,dd,hh,mn;//记录月份 日期 小时 分钟
    int state;//记录开始 结束 电话
    int flag;//记录是否输出 以及开始 结束电话
    int totaltime;//一通电话的时间
    double spend;//一通电话的花费
};
node rec[maxn];
int cmp(node a,node b){//排序
    if(strcmp(a.name, b.name) == 0){
        if(a.mm == b.mm){
            if(a.dd == b.dd){
                if(a.hh == b.hh)
                    return a.mn < b.mn;
                return a.hh < b.hh;
            }
            return a.dd < b.dd;
        }
        return a.mm < b.mm;
    }
    return strcmp(a.name, b.name) < 0;
}
void caculat(int s,int e){//计算一通电话的时间 花费
    int sumtime = (rec[e].dd - rec[s].dd) * 24 * 60 + (rec[e].hh - rec[s].hh) * 60 + rec[e].mn - rec[s].mn;
    rec[e].totaltime = sumtime;
    int j=0,sd=rec[s].dd,sh=rec[s].hh,sm=rec[s].mn;
    double sum=0;
    for(int i = 0; i < sumtime; ++i){
        j++, sm++;
        if(sm == 60){
            sum += (j * sal[sh] / 100.0);
            sh++;
            sm = 0;
            j = 0;
        }
        if(sh == 24){
            sd++;
            sh = 0;
        }
    }
    sum += (j * sal[sh] / 100.0);
    rec[e].spend = sum;
    return ;
}
int judge(double x){//判0
    if(x < 1e-5 && x > -1e-5)
        return 0;
    return 1;
}
int main()
{
    char temstate[20];
    for(int i = 0; i < 24; ++i){
        scanf("%d", &sal[i]);
    }
    scanf("%d", &n);
    for(int i = 0; i < n; ++i){
        scanf("%s", rec[i].name);
        scanf("%d:%d:%d:%d", &rec[i].mm, &rec[i].dd, &rec[i].hh, &rec[i].mn);
        scanf("%s", temstate);
        if(temstate[1] == 'n')
            rec[i].state = 1;
        else
            rec[i].state = -1;
        rec[i].flag = 0;
        rec[i].spend = 0;
    }
    sort(rec, rec + n, cmp);
    for(int i = 0; i < n; ++i){
        while(i < n && strcmp(rec[i].name, rec[i + 1].name) == 0){
            if(rec[i].state == 1 && rec[i + 1].state == -1){
                caculat(i, i + 1);
                if(judge(rec[i + 1].spend)){
                    rec[i].flag = 1;//开始电话
                    rec[i + 1].flag = -1;//结束电话
                }
                i += 2;
            }
            else
                i++;
        }
    }
    for(int i = 0; i < n; ++i){
        int flag = 0, j = i;
        double sum=0;
        while(j < n && strcmp(rec[i].name, rec[++j].name) == 0);
        while( i < j){
            if(!flag && rec[i].flag == 1){
                flag=1;
                printf("%s %02d\n", rec[i].name, rec[i].mm);
            }
            if(rec[i].flag == 1)
                printf("%02d:%02d:%02d ", rec[i].dd, rec[i].hh, rec[i].mn);
            if(rec[i].flag == -1){
                sum += rec[i].spend;
                printf("%02d:%02d:%02d %d $%.2lf\n", rec[i].dd, rec[i].hh, rec[i].mn, rec[i].totaltime, rec[i].spend);
            }
            i++;
        }
        if(flag){
            printf("Total amount: $%.2lf\n", sum);
        }
        i--;
    }
    return 0;
}
内容概要:本文详细介绍了基于FPGA的144输出通道可切换电压源系统的设计与实现,涵盖系统总体架构、FPGA硬件设计、上位机软件设计以及系统集成方案。系统由上位机控制软件(PC端)、FPGA控制核心和高压输出模块(144通道)三部分组成。FPGA硬件设计部分详细描述了Verilog代码实现,包括PWM生成模块、UART通信模块和温度监控模块。硬件设计说明中提及了FPGA选型、PWM生成方式、通信接口、高压输出模块和保护电路的设计要点。上位机软件采用Python编写,实现了设备连接、命令发送、序列控制等功能,并提供了一个图形用户界面(GUI)用于方便的操作和配置。 适合人群:具备一定硬件设计和编程基础的电子工程师、FPGA开发者及科研人员。 使用场景及目标:①适用于需要精确控制多通道电压输出的实验环境或工业应用场景;②帮助用户理解和掌握FPGA在复杂控制系统中的应用,包括PWM控制、UART通信及多通道信号处理;③为研究人员提供一个可扩展的平台,用于测试和验证不同的电压源控制算法和策略。 阅读建议:由于涉及硬件和软件两方面的内容,建议读者先熟悉FPGA基础知识和Verilog语言,同时具备一定的Python编程经验。在阅读过程中,应结合硬件电路图和代码注释,逐步理解系统的各个组成部分及其相互关系。此外,实际动手搭建和调试该系统将有助于加深对整个设计的理解。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值