HDU4496 D-City【并查集删边】

D-City

Problem Description
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.

Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.

Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.

Sample Input
5 10
0 1
1 2
1 3
1 4
0 2
2 3
0 4
0 3
3 4
2 4

Sample Output
1
1
1
2
2
2
2
3
4
5
Hint

The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there’s only 1 connected block at first.
The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together.
But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block.
Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.

Source
2013 ACM-ICPC吉林通化全国邀请赛——题目重现

题目大意:n个点m条边,给出边 然后问当删掉前k条边时 有几个连通块 k从1到m 输出共m行
分析:并查集本身是不存在删边的 所以就是反着来 倒着添边 记录连通块数 反着输出 具体看代码

#include <iostream>
#include<cstdio>
#include<cstring>
#define maxn 10010
#define maxm 100010
using namespace std;
int n,m;
struct node{
    int u,v;
};
node edge[maxm];
int pre[maxn];
void init(){
    for(int i=0;i<=n;++i)
        pre[i]=i;
}
int find_p(int x){
    return pre[x]==x?x:pre[x]=find_p(pre[x]);
}
void join(int a,int b){
    int fa=find_p(a);
    int fb=find_p(b);
    if(fa!=fb)
        pre[fa]=fb;
}
int main()
{
    int u,v,cnt,ans[maxm];
    while(~scanf("%d%d",&n,&m)){
        init();
        for(int i=0;i<m;++i){
            scanf("%d%d",&u,&v);
            edge[i].u=++u;
            edge[i].v=++v;
        }
        cnt=n;//删完时为n
        for(int i=m-1;i>=0;--i){//倒着添边 计算删除从0到i条边时的连通块数
            if(find_p(edge[i].u)!=find_p(edge[i].v)){
                ans[i]=cnt--;//当添加一条本不连通的边时 连通块数减一
                join(edge[i].u,edge[i].v);
            }
            else
                ans[i]=cnt;
        }
        for(int i=0;i<m;++i)
            printf("%d\n",ans[i]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值