这题就是求因子的个数,这题关键在于不要超时,还有就是如何转换题目的意思,i*j+i+j=n--->(i+1)*(j+1)=(n+1);
An easy problem
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 6539 Accepted Submission(s): 1598
Problem Description
When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..
One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :
Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?
Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?

One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :
Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?
Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?
Input
The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10
10).
Output
For each case, output the number of ways in one line.
Sample Input
2 1 3
Sample Output
0 1
#include<math.h>
int main()
{
__int64 i,j,n,m;
while(scanf("%I64d",&n)!=EOF)
{
while(n--)
{
scanf("%I64d",&m);
__int64 temp=sqrt(m+1);
__int64 f=0;
for(i=2;i<=temp;i++)
{
if((m+1)%i==0)
f++;
}
printf("%I64d\n",f);
f=0;
}
}
return 0;
}