Graph Theory HDU - 6029

本文介绍了一种名为CoolGraph的特殊图结构,并提供了一个用于检测此类图是否具有完美匹配的程序实现。通过输入一系列决策来生成CoolGraph,该程序能够判断是否存在一种方式使得图中的每个顶点都能恰好被一条边覆盖。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Little Q loves playing with different kinds of graphs very much. One day he thought about an interesting category of graphs called ``Cool Graph'', which are generated in the following way:
Let the set of vertices be {1, 2, 3, ..., nn}. You have to consider every vertice from left to right (i.e. from vertice 2 to nn). At vertice ii, you must make one of the following two decisions:
(1) Add edges between this vertex and all the previous vertices (i.e. from vertex 1 to i−1i−1).
(2) Not add any edge between this vertex and any of the previous vertices.
In the mathematical discipline of graph theory, a matching in a graph is a set of edges without common vertices. A perfect matching is a matching that each vertice is covered by an edge in the set.
Now Little Q is interested in checking whether a ''Cool Graph'' has perfect matching. Please write a program to help him.
Input
The first line of the input contains an integer T(1≤T≤50)T(1≤T≤50), denoting the number of test cases.
In each test case, there is an integer n(2≤n≤100000)n(2≤n≤100000) in the first line, denoting the number of vertices of the graph.
The following line contains n−1n−1 integers a2,a3,...,an(1≤ai≤2)a2,a3,...,an(1≤ai≤2), denoting the decision on each vertice.
Output
For each test case, output a string in the first line. If the graph has perfect matching, output ''Yes'', otherwise output ''No''.
Sample Input
3
2
1
2
2
4
1 1 2
Sample Output
Yes
No

No


题意:输入N组数据,每组数据输入一个n,接下来输入n-1个数,如果输入的是1,证明它可以和前面的任意一个节点相连,如果输入的是2,则不能和前面的节点相连。

判断能不能构成完美匹配。

完美匹配:如果一个图的某个匹配中,所有的顶点都是匹配点,那么它就是一个完美匹配。


#include<stdio.h>
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int sum=0;
        int n,res[100010];
        scanf("%d",&n);
        for(int i=1; i<n; i++)
            scanf("%d",&res[i]);
        for(int i=1; i<n; i++)
        {
            if(i>sum && res[i]==1)
                sum+=2;
        }
        if(!(n%2) && sum==n)
            printf("Yes\n");
        else

            printf("No\n");
    }
    return 0;
}
//res[i]=2表示的是和前面的节点不相交,但是可以和后面res[i]=1的节点相交


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值