华为OJ 初级:输入一行字符,分别统计出包含英文字母、空格、数字和其它字符的个数

本文介绍了一种方法来统计输入字符串中英文字母、空格、数字和其他字符的数量,并提供了完整的Java实现代码。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

描述

输入一行字符,分别统计出包含英文字母、空格、数字和其它字符的个数。

 

    /**
     * 统计出英文字母字符的个数。
     * 
     * @param str 需要输入的字符串
     * @return 英文字母的个数
     */
    public static int getEnglishCharCount(String str)
    {
        return 0;
    }
    
    /**
     * 统计出空格字符的个数。
     * 
     * @param str 需要输入的字符串
     * @return 空格的个数
     */
    public static int getBlankCharCount(String str)
    {
        return 0;
    }
    
    /**
     * 统计出数字字符的个数。
     * 
     * @param str 需要输入的字符串
     * @return 英文字母的个数
     */
    public static int getNumberCharCount(String str)
    {
        return 0;
    }
    
    /**
     * 统计出其它字符的个数。
     * 
     * @param str 需要输入的字符串
     * @return 英文字母的个数
     */
    public static int getOtherCharCount(String str)
    {
        return 0;
    }

 

 

知识点 字符串
运行时间限制 10M
内存限制 128
输入

输入一行字符串,可以有空格

输出

统计其中英文字符,空格字符,数字字符,其他字符的个数

样例输入 1qazxsw23 edcvfr45tgbn hy67uj m,ki89ol.\\/;p0-=\\][
样例输出 26 3 10 12
import java.util.Scanner;

public class Main{
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		String input = sc.nextLine();
		sc.close();
		int charNum = countChar(input);
		int blankNum = countBlank(input);
		int num = countNum(input);
		int others = input.length() - charNum - num - blankNum;
		System.out.println(charNum);
		System.out.println(blankNum);
		System.out.println(num);
		System.out.println(others);
	}

	private static int countChar(String input) {
		int count = 0;
		for (int i = 0; i < input.length(); i++) {
			if ((input.charAt(i) >= 'a' && input.charAt(i) <= 'z')
					|| (input.charAt(i) >= 'A' && input.charAt(i) <= 'Z'))
				count++;
		}
		return count;
	}

	private static int countBlank(String input) {
		int count = 0;
		for (int i = 0; i < input.length(); i++) {
			if (input.charAt(i) == ' ')
				count++;
		}
		return count;
	}

	private static int countNum(String input) {
		int count = 0;
		for (int i = 0; i < input.length(); i++) {
			if ((input.charAt(i) >= '0') && (input.charAt(i) <= '9'))
				count++;
		}
		return count;
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值