Fibonacci Again
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 37227 Accepted Submission(s): 17969
Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
Output
Print the word "yes" if 3 divide evenly into F(n).
Print the word "no" if not.
Print the word "no" if not.
Sample Input
0 1 2 3 4 5
Sample Output
no no yes no no no
其实就是很简单的题目,可是我就知道暴力,暴力就是没过去。醉了。。。。。。
还是老实的找规律吧!
n%4==2的时候就可以被3除尽!
代码:
#include <stdio.h>
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
int n;
while(cin>>n)
{
if(n%4==2)
cout<<"yes"<<endl;
else
cout<<"no"<<endl;
}
return 0;
}