poj 2349 Arctic Network

Arctic Network
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 23234 Accepted: 7139
Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).
Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input

1
2 4
0 100
0 300
0 600
150 750
Sample Output

212.13

题意: 有m个卫星和n个哨岗,装卫星的村庄可以自由联络不受限制,其余n-m个村庄只能通过radio连接,为了方便维护每个radio的接收范围都是一致的,求每个radio的最小范围。

做法: n个哨岗存在n-1条边,用prime算法跑一下最小生成树,开一个数组存一下每条边的长度,然后用卫星替代最长的边,剩下的边中最长的即为所求。

这题写完之后怎么交都是WA,搞了半天最后才知道是输出的问题,在G++下提交double 格式是%f,下面附一张区别的图

这里写图片描述

#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <cmath>
using namespace std;
const int maxn = 550;
double edge[maxn][maxn];
double lowcost[maxn];
bool vis[maxn];
double length[maxn];
double INF = 1000000000;
int n,m;
struct node
{
    double x,y;
}a[maxn];
void prim(int num)
{
    int p = 0;
    vis[num] = 1;
    for(int i = 1; i <= n; i++)
    {
        lowcost[i] = edge[num][i];
    }
    for(int i = 1; i < n; i++)
    {
        double minn = INF;
        int temp;
        for(int j =  1; j <= n; j++)
        {
            if(vis[j] == 0 && lowcost[j] < minn)
            {
                minn = lowcost[j];
                temp = j;
            }
        }
        vis[temp] = 1;
        length[p++] = minn;
        for(int j = 1; j <= n; j++)
        {
            if(lowcost[j] > edge[temp][j])
            {
                lowcost[j] = edge[temp][j];
            }
        }
    }
    sort(length,length+p);
    printf("%.2f\n",length[p-m]);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(vis,0,sizeof(vis));
        scanf("%d%d",&m,&n);
        for(int i = 1; i <= n; i++)
        {
            scanf("%lf%lf",&a[i].x,&a[i].y);
        }
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                edge[i][j] = sqrt((a[i].x-a[j].x)*(a[i].x-a[j].x)+(a[i].y-a[j].y)*(a[i].y-a[j].y));
            }
        }
        prim(1);
    }
    return 0;
}
标题Python网络课程在线学习平台研究AI更换标题第1章引言介绍Python网络课程在线学习平台的研究背景、意义、国内外现状和研究方法。1.1研究背景与意义阐述Python在线学习平台的重要性和研究意义。1.2国内外研究现状概述国内外Python在线学习平台的发展现状。1.3研究方法与论文结构介绍本文的研究方法和整体论文结构。第2章相关理论总结在线学习平台及Python教育的相关理论。2.1在线学习平台概述介绍在线学习平台的基本概念、特点和发展趋势。2.2Python教育理论阐述Python语言教学的理论和方法。2.3技术支持理论讨论构建在线学习平台所需的技术支持理论。第3章Python网络课程在线学习平台设计详细介绍Python网络课程在线学习平台的设计方案。3.1平台功能设计阐述平台的核心功能,如课程管理、用户管理、学习跟踪等。3.2平台架构设计给出平台的整体架构,包括前后端设计、数据库设计等。3.3平台界面设计介绍平台的用户界面设计,强调用户体验和易用性。第4章平台实现与测试详细阐述Python网络课程在线学习平台的实现过程和测试方法。4.1平台实现介绍平台的开发环境、技术栈和实现细节。4.2平台测试对平台进行功能测试、性能测试和安全测试,确保平台稳定可靠。第5章平台应用与效果分析分析Python网络课程在线学习平台在实际应用中的效果。5.1平台应用案例介绍平台在实际教学或培训中的应用案例。5.2效果评估与分析通过数据分析和用户反馈,评估平台的应用效果。第6章结论与展望总结Python网络课程在线学习平台的研究成果,并展望未来发展方向。6.1研究结论概括本文关于Python在线学习平台的研究结论。6.2研究展望提出未来Python在线学习平台的研究方向和发展建议。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值