So Easy!
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 5416 Accepted Submission(s): 1803
Problem Description
A sequence S
n is defined as:
Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate S n.
You, a top coder, say: So easy!

Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate S n.
You, a top coder, say: So easy!

Input
There are several test cases, each test case in one line contains four positive integers: a, b, n, m. Where 0< a, m < 2
15, (a-1)
2< b < a
2, 0 < b, n < 2
31.The input will finish with the end of file.
Output
For each the case, output an integer S
n.
Sample Input
2 3 1 2013 2 3 2 2013 2 2 1 2013
Sample Output
4 14 4
Source
ac代码:
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<map>
#include<iostream>
#include<sstream>
#define LL long long
#define INF 0x3f3f3f3f
#define INFLL 0x3f3f3f3f3f3f3f
#define lson rt<<1
#define rson rt<<1|1
using namespace std;
LL a,b,n,m;
struct mat
{
LL a[2][2];
mat()
{
memset(a,0,sizeof(a));
}
mat operator *(const mat &b) const
{
mat ret;
for(int i = 0;i<2;i++){
for(int j = 0;j<2;j++){
for(int k = 0;k<2;k++){
ret.a[i][k] = ((ret.a[i][k]%m+this->a[i][j]%m*b.a[j][k]%m)+m)%m;
}
}
}
return ret;
}
};
mat pow(mat a,LL nn)
{
mat ret;
for(int i = 0;i<2;i++)
{
for(int j = 0;j<2;j++)
{
ret.a[i][j] = (i==j);
}
}
while(nn){
if(nn&1) ret = a*ret;
a = a*a;
nn>>=1;
}
return ret;
}
int main()
{
while(~scanf("%lld%lld%lld%lld",&a,&b,&n,&m))
{
mat ans;
LL a1 = 2*a;
LL a2 = 2*a*a+2*b;
ans.a[0][0] = 2*a;
ans.a[0][1] = -a*a+b;
ans.a[1][0] = 1;
if(n==2){
printf("%lld\n",a2%m);
}
else if(n==1){
printf("%lld\n",a1%m);
}
else{
ans = pow(ans,n-2);
printf("%lld\n",((ans.a[0][0]%m*a2%m+ans.a[0][1]%m*a1%m)%m+m)%m);
}
}
}