Bone Collector(01背包)

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?


Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14

题意:01背包问题,求物品放入背包能获得的最大价值

题解:

F[i,j]:前i件物品放入容量为v的背包,故可以将问题转化为动态问题中的自底向上,也就是说考虑第i-1件的问题

考虑如果第i件物品放不放?
如果不放,则F[i-1,v]
如果放,则F[i-1,v-C[i]]

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
//物品价值 
int val[1005];
//物品体积 
int vol[1005]; 
int dp[1005][1005];
int main(){
	int t;
	cin>>t;
	while(t--){
		//背包可容纳的总数量 
		int n;
		//背包可容纳的总体积 
		int v;	
		cin>>n>>v;
		for(int i=1;i<=n;i++)
			cin>>val[i];
		for(int i=1;i<=n;i++)
			cin>>vol[i];
		//初始化
		for(int i=0;i<=n;i++)
			dp[i][0]=0;
		for(int j=0;j<=v;j++)
			dp[0][j]=0;
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)
			for(int j=0;j<=v;j++)
				if(j<vol[i])
					dp[i][j]=dp[i-1][j];
				else
					dp[i][j]=max(dp[i-1][j],dp[i-1][j-vol[i]]+val[i]);
		cout<<dp[n][v]<<endl;
	}
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值