矩形类定义

Description
定义一个矩形类,数据成员包括左下角和右上角坐标,定义的成员函数包括必要的构造函数、输入坐标的函数,以及计算并输出矩形面积的函数。要求使用提示中给出的测试函数并不得改动。
Input
四个数,分别表示矩形左下角和右上角顶点的坐标,如输入3.7 0.4 6.5 4.9,代表左下角坐标为(3.7, 0.4),右上角坐标为(6.5, 4.9)。
Output
输出一共有3行(请参考提示(hint)中的main函数):
第一行:由输入的坐标确定的矩形对象p1的面积
第二行:由对象复制得到的矩形对象p2的面积
第三行:直接初始化得到的矩形对象p3的面积

Sample Input
3.7 0.4 6.5 4.9
Sample Output
12.6
12.6
10

#include <iostream>
using namespace std;
class Rectangle
{
public:
 Rectangle(double=1,double=1,double=1,double=1);
   void input();
   void output();
 Rectangle(Rectangle &b)
{x1=b.x1;
 y1=b.y1;
 x2=b.x2;
 y2=b.y2;
}
private:
	double x1;
	double y1;
	double x2;
	double y2;
};
Rectangle::Rectangle(double a,double b,double c,double d)
{  x1=a;y1=b;x2=c;y2=d;}

void Rectangle::input()
{
	cin>>x1;
	cin>>y1;
	cin>>x2;
	cin>>y2;
}
void Rectangle::output()
{
	cout<<((y2-y1)*(x2-x1))<<endl;
}
int main()
{
    Rectangle p1;
    p1.input();
    p1.output();
    Rectangle p2(p1);
    p2.output();
    Rectangle p3(1,1,6,3);
    p3.output();
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值