POJ-1850 Code

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 9132 Accepted: 4360

Description

Transmitting and memorizing information is a task that requires different coding systems for the best use of the available space. A well known system is that one where a number is associated to a character sequence. It is considered that the words are made only of small characters of the English alphabet a,b,c, ..., z (26 characters). From all these words we consider only those whose letters are in lexigraphical order (each character is smaller than the next character).

The coding system works like this:
• The words are arranged in the increasing order of their length.
• The words with the same length are arranged in lexicographical order (the order from the dictionary).
• We codify these words by their numbering, starting with a, as follows:
a - 1
b - 2
...
z - 26
ab - 27
...
az - 51
bc - 52
...
vwxyz - 83681
...

Specify for a given word if it can be codified according to this coding system. For the affirmative case specify its code.

Input

The only line contains a word. There are some constraints:
• The word is maximum 10 letters length
• The English alphabet has 26 characters.

Output

The output will contain the code of the given word, or 0 if the word can not be codified.

Sample Input

bf

Sample Output

55

Source

Romania OI 2002

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int f[27][27],h[11],dp[11],ans;
char s[11];
int main()
{
	f[0][0] = 1;
	for(int i = 1;i <= 26;i++)
	{
		f[i][0]=1;
		for(int j = 1;j <= i;j++)
		 f[i][j] = f[i-1][j-1] + f[i-1][j];
	}
	for(int i = 1;i <= 10;i++)
     dp[i] = dp[i-1] + f[26][i];
	cin.sync_with_stdio(false);
	cin>>s;
	int n = strlen(s);
	for(int i = 1;i <= n;i++)
	 h[i] = s[i-1] - 'a' + 1;
	int maxn = 0;
	for(int i = 1;i <= n;i++)
	 if(h[i] <= h[i-1])
	 {
	 	cout<<0<<endl;
	 	return 0;
	 }
	ans+=dp[n-1]+1;
	for(int i = 1;i <= n;i++)
	{
		int now = h[i-1] + 1;
		if (now == h[i]) continue;
		for(int j = now;j < h[i];j++)
		 ans+=f[26-j][n-i];
	} 
	cout<<ans<<endl;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值