poj 1016 Numbers That Count 字符串操作

Numbers That Count
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 18359 Accepted: 6104

Description

"Kronecker's Knumbers" is a little company that manufactures plastic digits for use in signs (theater marquees, gas station price displays, and so on). The owner and sole employee, Klyde Kronecker, keeps track of how many digits of each type he has used by maintaining an inventory book. For instance, if he has just made a sign containing the telephone number "5553141", he'll write down the number "5553141" in one column of his book, and in the next column he'll list how many of each digit he used: two 1s, one 3, one 4, and three 5s. (Digits that don't get used don't appear in the inventory.) He writes the inventory in condensed form, like this: "21131435". 

The other day, Klyde filled an order for the number 31123314 and was amazed to discover that the inventory of this number is the same as the number---it has three 1s, one 2, three 3s, and one 4! He calls this an example of a "self-inventorying number", and now he wants to find out which numbers are self-inventorying, or lead to a self-inventorying number through iterated application of the inventorying operation described below. You have been hired to help him in his investigations. 

Given any non-negative integer n, its inventory is another integer consisting of a concatenation of integers c1 d1 c2 d2 ... ck dk , where each ci and di is an unsigned integer, every ci is positive, the di satisfy 0<=d1<d2<...<dk<=9, and, for each digit d that appears anywhere in n, d equals di for some i and d occurs exactly ci times in the decimal representation of n. For instance, to compute the inventory of 5553141 we set c1 = 2, d1 = 1, c2 = 1, d2 = 3, etc., giving 21131435. The number 1000000000000 has inventory 12011 ("twelve 0s, one 1"). 

An integer n is called self-inventorying if n equals its inventory. It is called self-inventorying after j steps (j>=1) if j is the smallest number such that the value of the j-th iterative application of the inventory function is self-inventorying. For instance, 21221314 is self-inventorying after 2 steps, since the inventory of 21221314 is 31321314, the inventory of 31321314 is 31123314, and 31123314 is self-inventorying. 

Finally, n enters an inventory loop of length k (k>=2) if k is the smallest number such that for some integer j (j>=0), the value of the j-th iterative application of the inventory function is the same as the value of the (j + k)-th iterative application. For instance, 314213241519 enters an inventory loop of length 2, since the inventory of 314213241519 is 412223241519 and the inventory of 412223241519 is 314213241519, the original number (we have j = 0 in this case). 

Write a program that will read a sequence of non-negative integers and, for each input value, state whether it is self-inventorying, self-inventorying after j steps, enters an inventory loop of length k, or has none of these properties after 15 iterative applications of the inventory function.

Input

A sequence of non-negative integers, each having at most 80 digits, followed by the terminating value -1. There are no extra leading zeros.

Output

For each non-negative input value n, output the appropriate choice from among the following messages (where n is the input value, j is a positive integer, and k is a positive integer greater than 1): 
n is self-inventorying 
n is self-inventorying after j steps 
n enters an inventory loop of length k 
n can not be classified after 15 iterations

Sample Input

22 
31123314 
314213241519 
21221314 
111222234459 
-1

Sample Output

22 is self-inventorying 
31123314 is self-inventorying 
314213241519 enters an inventory loop of length 2 
21221314 is self-inventorying after 2 steps 
111222234459 enters an inventory loop of length 2 

Source


本题是对输入的由digit构成的字符串进行类型判断,解决该题目的主要步骤在于统计字符串中数字的个数和把统计情况转化为字符串,然后根据题目的要求判断并输出字符串的类别,有一些细节点需要注意,如有的字符可能会出现大于等于10以上次数的情况,将字符统计情况转化为字符串的时候,一定要在最后一个字符的后一位加上‘\0’,还有就是迭代次数的确定,题目规定超过15次的迭代仍无法归类的话需要归为无法归类的情况,要注意恰好在第15次迭代和第16次迭代能够分类的数据。

#include <cstdio>
#include <string.h>
char str[15][81];
int ct[10];
int main()
{
	int cursize = 0,t = 0;
	bool flag; //判断是否有字符串相等的标记
	while(scanf("%s", str[0]), str[0][0] != '-')
	{
		flag = false;

		for(int i = 0; i < 15; i++)
		{
			for(int k = 0; k < 10; k++)
				ct[k] = 0;

			cursize = strlen(str[i]);
			for(int j = 0; j < cursize; j++) //统计字符串的数字出现情况
				ct[str[i][j] - '0']++;
			
			t = 0;
			for(int j = 0; j < 10; j++) //将数字的统计情况转化为字符串
			{
				if(ct[j] != 0)
				{
					if(ct[j] >= 10)
						str[i + 1][t++] = (ct[j] / 10) + '0';
					str[i + 1][t++] = (ct[j] % 10) + '0';
					str[i + 1][t++] = j + '0';
				}
			}
			str[i+1][t] = '\0';   //重要的一个细节为字符串的最后一位之后的位置加上结束符
		
			for(int k = i; k >= 0; k--) //根据情况判断字符串的类型
			{
				if(strcmp(str[k], str[i + 1]) == 0)
				{
					flag = true;
					if(i == 0)
						printf("%s is self-inventorying \n", str[0]);
					else if(k == i)
						printf("%s is self-inventorying after %d steps\n", str[0], i);
					else
						printf("%s enters an inventory loop of length %d\n", str[0],
							i + 1 - k );
					break;
				}
			}
			if(flag)
				break;
		}
		if(!flag)
			printf("%s can not be classified after 15 iterations\n", str[0]);

	}

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值