poj 3660 Cow Contest

Cow Contest
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7016 Accepted: 3853

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cowA will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2
思路:先判断是否联通 然后分别统计个点的入度和出度之和靠是否为n-1 即可 传递闭包的性质出度和入度和为n-1的时候其顺序是唯一确定的
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stack>
#include <queue>
#include <set>
#include <vector>
using namespace std;
#define maxn  105
#define INF  1000000000
int d[maxn][maxn];

int n,m; 
void floyd(){
	int i,j,k;
	for(i=1;i<=n;i++){
		for(j=1;j<=n;j++){
			for(k=1;k<=n;k++){
				//if(d[j][i]!=-1&&d[i][k]!=-1)
			//	if(d[j][k]==-1)
		
				d[j][k]=d[j][k]||(d[j][i]&&d[i][k]);
			}
		}
	}
}
int main(){
	int i,j;
	int a,b;
	scanf("%d %d",&n,&m);
    memset(d,0,sizeof(d));
    for(i=0;i<m;i++){
      scanf("%d %d",&a,&b);
       d[a][b]=1;
	}
	floyd();
	int cnt=0,k=0;
	for(i=1;i<=n;i++){
		  k=0;
		for(j=1;j<=n;j++){
		  if(d[i][j]||d[j][i])
		  k++;
	  
		}
			if(k==n-1)
		cnt++;	
	}
	cout<<cnt<<endl;
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值