hdu 2612 Find a way

本文介绍了一种算法,用于计算两个角色从不同起点出发,在一张地图上寻找最近的会面地点的方法。通过两次广度优先搜索(BFS),算法能够找到两人到达同一地点的最短时间。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
 

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
 

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
 

Sample Input
  
  
4 4 Y.#@ .... .#.. @..M 4 4 Y.#@ .... .#.. @#.M 5 5 Y..@. .#... .#... @..M. #...#
 

Sample Output
  
  
66 88 66
两个人分别从“Y”和“M”出发,到‘@’表示的KFC去,找出两人到达同一个KFC的最短时间,两次BFS然后找到最小时间。
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
#define inf 0x3f3f3f3f
int n,m,co;
char g[1005][1005];
bool vis[1005][1005];
int to[4][2]={0,1,0,-1,1,0,-1,0};
int px[1005],py[1005],a[1005],b[1005],c[1005];
struct node
{
    int x,y,st;
};
int fin(int x,int y)//找到到达的是哪个KFC
{
    int i;
    for(i=0;i<co;i++)
        if(px[i]==x&&py[i]==y)
        return i;
    return 0;
}
void bfs(int x,int y,int *p)
{
    int i,j;
    node l,r;
    queue<node> q;
    memset(vis,0,sizeof vis);
    memset(c,0,sizeof c);
    l.x=x,l.y=y,l.st=0;
    vis[x][y]=1;
    q.push(l);
    while(!q.empty())
    {
        r=q.front();
        q.pop();
        int t=fin(r.x,r.y);
        if(t)
        {
            c[t]=r.st;
        }
        for(i=0;i<4;i++)
        {
            int nx=r.x+to[i][0],ny=r.y+to[i][1];
            if(nx>=0&&nx<n&&ny>=0&&ny<m&&!vis[nx][ny]&&g[nx][ny]!='#')
            {
                vis[nx][ny]=1;
                l.x=nx,l.y=ny,l.st=r.st+1;
                q.push(l);
            }
        }
    }
    for(i=1;i<co;i++)//到达每个KFC的最短时间分别存入数组
        if(c[i])
        p[i]=c[i];
    else
        p[i]=-1;

}
int main()
{
    int i,j,x1,x2,y1,y2;
    while(~scanf("%d%d",&n,&m))
    {
        co=1;
        for(i=0;i<n;i++)
        {
            scanf("%s",g[i]);
            for(j=0;j<m;j++)
            {
                if(g[i][j]=='Y')
                {
                    x1=i,y1=j;
                }
                if(g[i][j]=='M')
                {
                    x2=i,y2=j;
                }
                if(g[i][j]=='@')
                {
                    px[co]=i,py[co++]=j;
                }
            }
        }
        bfs(x1,y1,a);
        bfs(x2,y2,b);
        int ans=inf;
        for(i=1;i<co;i++)//找到同一个最小值
            if(a[i]!=-1&&b[i]!=-1)
            ans=min(a[i]+b[i],ans);
        printf("%d\n",ans*11);
    }
    return  0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值