A sequence of numbers

本文介绍了一个基于等差和等比序列的问题求解方法,并提供了一段C语言代码实现。该方法能够根据序列的前三个数字及指定位置,计算出序列中对应项的值并返回其模200907的结果。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem Description

Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.

Input

The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.

Output

Output one line for each test case, that is, the K-th number module (%) 200907.

Sample Input

2
1 2 3 5
1 2 4 5

Sample Output

5
16

Source

2009 Multi-University Training Contest 1 - Host by TJU
#include<stdio.h>
unsigned __int64 pow(__int64 a,__int64 b)
{
    unsigned __int64 c;
    c=1;
    while(b)
    {
        if(b%2==1)
        {
            c*=a;
            c%=200907;
        }
        
        a=((a%200907)*(a%200907))%200907;
        b/=2;
    
    }

    return c;
}

int main()
{
    int n;
    unsigned __int64 a,b,c,d,e;

    
    scanf("%d",&n);
    while(n--)
    {
        scanf("%I64d %I64d %I64d %I64d",&a,&b,&c,&d);

        
        if((c-b)==(b-a))//等差数列
        {
                 e=(a%200907+(((d-1)%200907)*((b-a)%200907))%200907)%200907;    //     等差数列公式 a[n]=a[1]+(n-1)*d;
        }

        else
        {
                  
            
            e=(a%200907*pow(b/a%200907,(d-1))%200907)%200907;    //     等比数列公式  a[n]=a[1]*q^(n-1);

        }

        printf("%I64d\n",e);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值