Problem Description
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.
Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.
You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
Output
Output one line for each test case, that is, the K-th number module (%) 200907.
Sample Input
2 1 2 3 5 1 2 4 5
Sample Output
5 16
Source
2009 Multi-University Training Contest 1 - Host by TJU
#include<stdio.h>
unsigned __int64 pow(__int64 a,__int64 b)
{
unsigned __int64 c;
c=1;
while(b)
{
if(b%2==1)
{
c*=a;
c%=200907;
}
a=((a%200907)*(a%200907))%200907;
b/=2;
}
return c;
}
int main()
{
int n;
unsigned __int64 a,b,c,d,e;
scanf("%d",&n);
while(n--)
{
scanf("%I64d %I64d %I64d %I64d",&a,&b,&c,&d);
if((c-b)==(b-a))//等差数列
{
e=(a%200907+(((d-1)%200907)*((b-a)%200907))%200907)%200907; // 等差数列公式 a[n]=a[1]+(n-1)*d;
}
else
{
e=(a%200907*pow(b/a%200907,(d-1))%200907)%200907; // 等比数列公式 a[n]=a[1]*q^(n-1);
}
printf("%I64d\n",e);
}
return 0;
}