Aggressive cows


http://poj.org/problem?id=2456

二分


Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5996 Accepted: 2986

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

先进行排序,然后,进入二分判断,第i+1头要满足a[i+1]-a[i]>d;

二分找就好


#include<iostream>
#include<math.h>
#include<algorithm>
using namespace std;
int n,cow;
int a[100009];
bool satisfied(int x)
{
	int num=0;
	for(int i=1;i<cow;i++)//默认第一头牛住在第一个商铺
	{
		int crt=num+1;
		while(crt<n &&a[crt]-a[num]<x)//crt在n的范围不断+1去满足条件
			crt++;
		if(crt==n)
			
			return false;
		num=crt;
	}
	return true;
}
int main()
{
	//freopen("in1.txt","r",stdin);
	
	while(cin>>n>>cow)
	{
		for(int i=0;i<n;i++)
			scanf("%d",&a[i]);
		int lb=0,ub=99999999;//初始化解的存在范围
		sort(a,a+n);
		while(ub-lb>1)//重复循环,直到解的存在范围	小1
		{
			
			int mid=(lb+ub)/2;
			cout<<mid<<endl;
			if(satisfied(mid))
			{
				lb=mid;//如果mid满足条件,则解得范围(lb,mid]
			}
			else
			{
				ub=mid;//如果mid不满足条件,则解的存在范围变为(mid,ub]
			}
		}
		printf("%d\n", lb);
	}
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值