poj2151 概率dp

http://poj.org/problem?id=2151

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms: 
1. All of the teams solve at least one problem. 
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems. 

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem. 

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems? 

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972
有T个队伍参加比赛,总共有m道题目,已知每个队伍解出每到题目的概率,求每个队伍至少做出一道题,并且冠军队伍至少做出n道题的概率。
解题思路:又是一道概率dp的题目,求出每个队伍至少做出1道题的概率p1和每个队伍做出1~-n-1道题目的概率p2。做差即为答案。现在问题转化为如何求解出1,2,3...k题的概率,假设dp[i][j][k]表示第i个队在前j题解出k题的概率 ,则: 
dp[i][j][k]=dp[i][j-1][k-1]*p[i][j]+dp[i][j-1][k]*(1-p[i][j]); 
所以x[i][M][k]表示的就是第i个队解出k题的概率
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;

double p[1005][35],dp[1005][35][35];
int n,m,t;

int main()
{
    while(~scanf("%d%d%d",&m,&t,&n))
    {
        if(n==0&&t==0&&m==0)
            break;
        double x,p1=1,p2=1;
        for(int i=1; i<=t; i++)
        {
            x=1.0;
            for(int j=1; j<=m; j++)
            {
                scanf("%lf",&p[i][j]);
                x*=(1-p[i][j]);
            }
            p1*=(1-x);
        }
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=t;i++)
        {
            dp[i][0][0]=1;
            for(int j=1;j<=m;j++)
            {
                for(int k=1;k<=m;k++)
                   dp[i][j][k]=dp[i][j-1][k-1]*p[i][j]+dp[i][j-1][k]*(1-p[i][j]);
                dp[i][j][0]=dp[i][j-1][0]*(1-p[i][j]);
            }
            x=0;
            for(int j=1;j<=n-1;j++)
                x+=dp[i][m][j];
            p2*=x;
        }
        printf("%.3lf\n",p1-p2);
    }
    return 0;
}

/*

2 2 2
0.9 0.9
1 0.9
0 0 0
**/

其实完全可以用二维数组来做:
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;

double p[1005][35],dp[35][35];
int n,m,t;

int main()
{
    while(~scanf("%d%d%d",&m,&t,&n))
    {
        if(n==0&&t==0&&m==0)
            break;
        double x,p1=1,p2=1;
        for(int i=1; i<=t; i++)
        {
            x=1.0;
            for(int j=1; j<=m; j++)
            {
                scanf("%lf",&p[i][j]);
                x*=(1-p[i][j]);
            }
            p1*=(1-x);
        }
        for(int i=1;i<=t;i++)
        {
            memset(dp,0,sizeof(dp));
            dp[0][0]=1;
            for(int j=1;j<=m;j++)
            {
                for(int k=1;k<=m;k++)
                   dp[j][k]=dp[j-1][k-1]*p[i][j]+dp[j-1][k]*(1-p[i][j]);
                dp[j][0]=dp[j-1][0]*(1-p[i][j]);
            }
            x=0;
            for(int j=1;j<=n-1;j++)
                x+=dp[m][j];
            p2*=x;
        }
        printf("%.3lf\n",p1-p2);
    }
    return 0;
}

/**

2 2 2
0.9 0.9
1 0.9
0 0 0

**/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值