2014多校联合第9场1006||hdu 4965 矩阵乘法和快速幂

本文介绍了一个涉及矩阵乘法、幂运算及模运算的编程问题。通过多次掷骰子生成矩阵,并进行复杂的数学运算来求解最终矩阵元素之和。文章提供了一段C++代码示例,演示如何使用矩阵快速幂等技巧解决该问题。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

http://acm.hdu.edu.cn/showproblem.php?pid=4965

Problem Description
One day, Alice and Bob felt bored again, Bob knows Alice is a girl who loves math and is just learning something about matrix, so he decided to make a crazy problem for her.

Bob has a six-faced dice which has numbers 0, 1, 2, 3, 4 and 5 on each face. At first, he will choose a number N (4 <= N <= 1000), and for N times, he keeps throwing his dice for K times (2 <=K <= 6) and writes down its number on the top face to make an N*K matrix A, in which each element is not less than 0 and not greater than 5. Then he does similar thing again with a bit difference: he keeps throwing his dice for N times and each time repeat it for K times to write down a K*N matrix B, in which each element is not less than 0 and not greater than 5. With the two matrix A and B formed, Alice’s task is to perform the following 4-step calculation.

Step 1: Calculate a new N*N matrix C = A*B.
Step 2: Calculate M = C^(N*N). 
Step 3: For each element x in M, calculate x % 6. All the remainders form a new matrix M’.
Step 4: Calculate the sum of all the elements in M’. 

Bob just made this problem for kidding but he sees Alice taking it serious, so he also wonders what the answer is. And then Bob turn to you for help because he is not good at math.
 

Input
The input contains several test cases. Each test case starts with two integer N and K, indicating the numbers N and K described above. Then N lines follow, and each line has K integers between 0 and 5, representing matrix A. Then K lines follow, and each line has N integers between 0 and 5, representing matrix B.

The end of input is indicated by N = K = 0.
 

Output
For each case, output the sum of all the elements in M’ in a line.
 

Sample Input
  
  
4 2 5 5 4 4 5 4 0 0 4 2 5 5 1 3 1 5 6 3 1 2 3 0 3 0 2 3 4 4 3 2 2 5 5 0 5 0 3 4 5 1 1 0 5 3 2 3 3 2 3 1 5 4 5 2 0 0
 

Sample Output
  
  
14 56
矩阵题。请看官方题解


#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
int a[1005][6],b[6][1005],c[6][6],s[1005][1005],sum[1005][6];
const int MAX=6;
int n,m;
struct Matrix
{
    int m[MAX][MAX];
};
Matrix I={1,0,0,0,0,0,
          0,1,0,0,0,0,
          0,0,1,0,0,0,
          0,0,0,1,0,0,
          0,0,0,0,1,0,
          0,0,0,0,0,1};
Matrix matrixmul(Matrix a,Matrix b)
{
    int i,j,k;
    Matrix c;
    for(i=0;i<m;i++)
        for(j=0;j<m;j++)
        {
           c.m[i][j]=0;
           for(k=0;k<m;k++)
            c.m[i][j]+=(a.m[i][k]*b.m[k][j])%6;
           c.m[i][j]%=6;
        }
    return c;
}
Matrix quickpow(Matrix P,int n)
{
    Matrix m=P,b=I;
    while(n>=1)
    {
        if(n&1)
            b=matrixmul(b,m);
        n=n>>1;
        m=matrixmul(m,m);
    }
    return b;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(s,0,sizeof(s));
        memset(c,0,sizeof(c));
        memset(sum,0,sizeof(sum));
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                 scanf("%d",&a[i][j]);
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
                 scanf("%d",&b[i][j]);
        for(int i=0;i<m;i++)
            for(int l=0;l<m;l++)
            {
               for(int j=0;j<n;j++)
                  c[i][l]+=b[i][j]*a[j][l];
            }
       /* for(int i=0;i<m;i++)
        {
            for(int j=0;j<m;j++)
                printf("%d ",c[i][j]);
            printf("\n");
        }*/
        Matrix A;
        for(int i=0;i<m;i++)
            for(int j=0;j<m;j++)
                A.m[i][j]=c[i][j];
        /* for(int i=0;i<m;i++)
        {
            for(int j=0;j<m;j++)
                printf("%d ",A.m[i][j]);
            printf("\n");
        }*/
        A=quickpow(A,n*n-1);

       /* printf("\n");
        for(int i=0;i<m;i++)
        {
            for(int j=0;j<m;j++)
                printf("%d ",A.m[i][j]);
            printf("\n");
        }
        printf("\n");
*/
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                for(int k=0;k<m;k++)
                    sum[i][j]+=a[i][k]*A.m[k][j];
        for(int i=0;i<n;i++)
            for(int k=0;k<n;k++)
            {
                for(int j=0;j<m;j++)
                     s[i][k]+=sum[i][j]*b[j][k];
                 s[i][k]%=6;
            }
        int ans=0;
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                ans+=s[i][j];
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值