HDU 1217

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 
 

Input

The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n. 
 

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No". 
 

Sample Input

       
       
3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0
 

Sample Output

       
       
Case 1: Yes Case 2: No
 






题意:给几个国家,然后给这些国家之间的汇率。判断能否通过这些汇率差进行套利交易。

Floyd的算法可以求出任意两点间的最短路径,最后比较本国与本国的汇率差,如果大于1,则可以。否则不可以。

最后只需查找是否存在map[i][i]大于1,若存在输出yes 否则no




#include<stdio.h>
#include<string.h>
int n;
char money[35][100];
double map[35][35];
char ch[100];
char ct[100];
int Strcmp(char ch[])
{
    int i;
    for(i=0;i<n;i++)
    {
        if(strcmp(ch,money[i])==0)
        return i;
    }
}
int floyd()
{
    int i,j,k;
    for(k=0;k<n;k++)
    {
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                if(map[i][j]<map[i][k]*map[k][j])
                map[i][j]=map[i][k]*map[k][j];
            }
        }
    }
    for(i=0;i<n;i++)
    {
        if(map[i][i]>1)
        return 1;
        break;
    }
    return 0;
}
int main()
{
    int i,j;
    int m;
    double s;
    int count=1;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                map[i][j]=0;
            }
        }
        for(i=0;i<n;i++)
        {
            scanf("%s",&money[i]);
        }
        scanf("%d",&m);
        while(m--)
        {
            scanf("%s%lf%s",ch,&s,ct);
            int i=Strcmp(ch);
            int j=Strcmp(ct);
            map[i][j]=s;

        }
        printf("Case %d: ",count++);
        int result=floyd();
        if(result==1)
        printf("Yes\n");
        else
        printf("No\n");

    }

}

最短路Floyd算法变形
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值