Idiomatic Phrases Game
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1528 Accepted Submission(s): 482
Problem Description
Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.
Input
The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case.
Output
One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.
Sample Input
5 5 12345978ABCD2341 5 23415608ACBD3412 7 34125678AEFD4123 15 23415673ACC34123 4 41235673FBCD2156 2 20 12345678ABCD 30 DCBF5432167D 0
Sample Output
17 -1
Author
ZHOU, Ran
Source
Recommend
linle
题意是说每个成语是由四个字组成,每个字由四个16进制数字表示。现在给你多个成语,每个成语都有一个花费,让你以第一个成语第一个字开始,最后一个字最后一个字结束。让你在给出的成语字典里面找出一个序列,这个序列要求以前一个成语的最后一个字必须和后一个成语的第一个字一样,让你求最小花费时间。
最短路的变形。
<pre name="code" class="cpp">#include<stdio.h>
#include<string.h>
#define max 1005
#define inf 99999999
int n;
int cost[max];//存储每一个花费的时间
int vis[max];//存储访问情况
char str[max][max];
int map[max][max];//存储可以接龙的一对花费的时间
int time[max];//最小花费时间
int dijksa()
{
int i,j,k;
memset(vis,0,sizeof(vis));
for(i=0;i<n;i++)
{
time[i]=inf;
}
time[0]=0;
for(i=0;i<n;i++)
{
int min=inf;
int u=0;
for(j=0;j<n;j++)
{
if(!vis[j]&&time[j]<min)
{
min=time[j];
u=j;
}
}
vis[u]=1;
for(k=0;k<n;k++)
{
if(map[u][k]!=-1&&map[u][k]+time[u]<time[k])
{
time[k]=map[u][k]+time[u];
}
}
}
return time[n-1];
}
int main()
{
int i,j,k;
while(scanf("%d",&n)!=EOF&&n)
{
memset(cost,0,sizeof(cost));
memset(str,0,sizeof(str));
for(i=0;i<n;i++)
{
scanf("%d%s",&cost[i],str[i]);
}
memset(map,-1,sizeof(map));
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
{
if(i==j)
continue;
int len=strlen(str[i]);
for(k=0;k<4;k++)
{
if(str[i][len-4+k]!=str[j][k])
break;
}
if(k==4)
{
map[i][j]=cost[i];
}
}
}
int ans=dijksa();
if(ans==inf)
{
printf("-1\n");
}
else
printf("%d\n",ans);
}
return 0;
}