HDU - 2492Ping pong(树状数组|权值线段树)

Ping pong

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5424 Accepted Submission(s): 2020

Problem Description
N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment).

Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee’s house. For some reason, the contestants can’t choose a referee whose skill rank is higher or lower than both of theirs.

The contestants have to walk to the referee’s house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input
The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case.

Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 … aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 … N).

Output
For each test case, output a single line contains an integer, the total number of different games.

Sample Input
1
3 1 2 3

Sample Output
1

Source
2008 Asia Regional Beijing

Recommend
gaojie

题意:

问有多少个三元组满足i

a[i]<=a[j]<=a[k]||a[i]>=a[k]>=a[j]

那就前后开树状数组或者线段树维护信息即可。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
typedef long long LL;
const int maxn=1e5+5;

int S[maxn],T[maxn],n,a[maxn];

inline void add(int *T,int x,int val)
{
  for(;x<=100000;x+=x&-x)T[x]+=val;
}

inline LL sum(int *T,int x)
{
  LL ans=0;
  for(;x;x-=x&-x)ans+=T[x];
  return ans;
}

int main()
{
  int t;
  scanf("%d",&t); 
  while(t--)
  {
    scanf("%d",&n);
    for(int i=1;i<=n;++i)scanf("%d",a+i);
    memset(S,0,sizeof(S));
    memset(T,0,sizeof(T));
    for(int i=1;i<=n;++i)add(T,a[i],1);
    LL ans=0;
    for(int i=1;i<=n;++i)
    {
      add(T,a[i],-1);
      ans+=sum(S,a[i])*(n-i-sum(T,a[i]-1));
      ans+=(i-1-sum(S,a[i]-1))*sum(T,a[i]);
      add(S,a[i],+1);
    }
    printf("%lld\n",ans);
  }
  return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值