HDU 1703 PBD 递推

这一题推了半天也没有推出来,推的时候各种复杂啊!感觉自己弱暴了没,思考问题的方法不行!现在看了别人的报告只能说是想通了。当n大于等于5的思路大致是这样的:(PS递归的问题,总是要基于前一个状态的,所以一般从前一个状态分析起)。假如有ABCD四个人,他们完成信息交流需要f次,那末,五个人的时候,比如添加了E,可以首先让E与A进行一次信息交流,这时他们的信息互换,可以看作E和A为一个人,而E的信息也随A传递,那么这时仍然经过f次,ABCD四个人的信息交流完毕,而且信息中也都含有E的信息。此时,ABCD四个人已经都掌握其他所有人的信息,只剩下E,再让E与他们任何一一个人一次信息交流即可。所以:f[n]=f[n-1]+2


Description

PrisonBreak is a popular TV programme in HDU. ACboy likes it very much, and he join a PrisonBreak discussing team called "PBD".Every Tuesday night, a lot of PBDers will contact with each other to discuss the newest plot of PrisonBreak season2. Generally speaking, every PBDer has distinct ideas about the play, so everyone want to know all the others' ideas. For example, when ACboy contract with Sam, ACboy will tell all the ideas he konws to Sam, and Sam will also tell all the ideas he konws to ACboy, and the call costs 5 yuan. 
If there are N people in the "PBD" team, what is the minimum cost to let everyone knows all the others' ideas?
 

Input

The input contains multiple test cases.
Each test case contains a number N, means there are N people in the "PBD" team.N = 0 ends the input.(A call cost 5 yuan).
 

Output

for each case, output a integer represent the minimum cost to let everyone knows all the others' ideas.
 

Sample Input

       
       
1 2 3 4 0
 

Sample Output

       
       
0 5 15 20

Hint

If there are 2 people, for example, named A, B. Then A calls B, then A and B will know each other's ideas, so it only
 needs one call, so the minimum cost is 1*5 = 5 yuan.
 
 

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
   int f[20000];
   f[1]=0;
   f[2]=1;
   f[3]=3;
   f[4]=4;
   for(int i=5;i<=10000;i++)
    f[i]=f[i-1]+2;
    int n;
    while(scanf("%d",&n)&&n)
    {
        printf("%d\n",f[n]*5);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值