Radar Installation
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 49398 | Accepted: 11037 |
Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2 1 2 -3 1 2 1 1 2 0 2 0 0
Sample Output
Case 1: 2 Case 2: 1
Source
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <ctype.h>
#include<algorithm>
using namespace std;
struct node
{
double x,y;
} a[1001];
bool cmp(node x,node y)
{
return x.x<y.x;
}
int main()
{
int n,d,i,j,x,y,l=0;
while(scanf("%d%d",&n,&d)!=EOF&&(n!=0&&d!=0))
{
l++;
int flag=0;
for(i=0; i<n; i++)
{
scanf("%d%d",&x,&y);
if(y>d)
flag=1;
a[i].x=x-sqrt(d*d-y*y);
a[i].y=x+sqrt(d*d-y*y);
}
if(flag)
{
printf("Case %d: -1\n",l);
continue;
}
sort(a,a+n,cmp);
int ans=1;
double border=a[0].y;
for(i=0; i<n; i++)
{
if(a[i].x>border)
{
ans++;
border=a[i].y;
}
if(a[i].y<border)
border=a[i].y;
}
printf("Case %d: %d\n",l,ans);
}
return 0;
}