hdu1213 - How Many Tables (基础并查集)

探讨如何计算在特定条件下,让互相认识的朋友坐在同一桌所需的最少桌数。使用并查集算法解决此问题。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13487    Accepted Submission(s): 6616


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
  
  
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
  
  
2 4
 

Author
Ignatius.L
 

Source
                 巩固下~  水水更健康
/******************************
*
*	acm:   hdu-1213
*
*	title: How Many Tables
*
*	time:  2014.8.11
*
******************************/

//考察并查集

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

#define MAXSIZE 1001


//查操作
int Find_Eg(int *parent, int f)
{
    int k = f;
    int temp;

    while (parent[f] > 0)
    {
        f = parent[f];
    }

    while (k != f)
    {
        temp = parent[k];
        parent[k] = f;
        k = temp;
    }

    return f;
}

//并操作
void Union_Eg(int *parent, int a, int b)
{
    int temp;

    a = Find_Eg(parent, a);
    b = Find_Eg(parent, b);

    temp = parent[a] + parent[b];

    if (a != b)
    {
        if (parent[a] > parent[b])
        {
            parent[a] = b;
            parent[b] = temp;
        }
        else
        {
            parent[b] = a;
            parent[a] = temp;
        }

    }
}

int main()
{
    int T;
    int i = 0;
    int j;
    int parent[MAXSIZE];
    int N;
    int M;
    int a, b;
    int num;

    scanf("%d", &T);

    while (i < T)
    {
        memset(parent, -1, sizeof(parent));

        scanf("%d%d", &N, &M);

        for (j = 0; j < M; j++)
        {
            scanf("%d%d", &a, &b);
            Union_Eg(parent, a, b);
        }

        num = 0;
        for (j = 1; j <= N; j++)
        {
            if (parent[j] < 0)
            {
                num++;
            }
        }

        printf("%d\n", num);

        i++;
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值