How Many Tables
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13487 Accepted Submission(s): 6616
Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5
Sample Output
2 4
Author
Ignatius.L
Source
巩固下~ 水水更健康
/******************************
*
* acm: hdu-1213
*
* title: How Many Tables
*
* time: 2014.8.11
*
******************************/
//考察并查集
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define MAXSIZE 1001
//查操作
int Find_Eg(int *parent, int f)
{
int k = f;
int temp;
while (parent[f] > 0)
{
f = parent[f];
}
while (k != f)
{
temp = parent[k];
parent[k] = f;
k = temp;
}
return f;
}
//并操作
void Union_Eg(int *parent, int a, int b)
{
int temp;
a = Find_Eg(parent, a);
b = Find_Eg(parent, b);
temp = parent[a] + parent[b];
if (a != b)
{
if (parent[a] > parent[b])
{
parent[a] = b;
parent[b] = temp;
}
else
{
parent[b] = a;
parent[a] = temp;
}
}
}
int main()
{
int T;
int i = 0;
int j;
int parent[MAXSIZE];
int N;
int M;
int a, b;
int num;
scanf("%d", &T);
while (i < T)
{
memset(parent, -1, sizeof(parent));
scanf("%d%d", &N, &M);
for (j = 0; j < M; j++)
{
scanf("%d%d", &a, &b);
Union_Eg(parent, a, b);
}
num = 0;
for (j = 1; j <= N; j++)
{
if (parent[j] < 0)
{
num++;
}
}
printf("%d\n", num);
i++;
}
return 0;
}