题目来自杭电:http://acm.hdu.edu.cn/showproblem.php?pid=1085
Holding Bin-Laden Captive!
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17440 Accepted Submission(s): 7814
Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
“Oh, God! How terrible! ”
Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds– 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.
Sample Input
1 1 3
0 0 0
Sample Output
4
代码:
#include <iostream>
#include <fstream>
#include <algorithm>
const int MAX = 1000 + 10;
using namespace std;
int main()
{
int a,b,c;
int i,j;
int sum;
while(cin >> a >> b >> c)
{
if(a == 0 && b == 0 && c == 0)
break;
for(i = 1;; i++)
{
sum = 0;
//先判断5
for(j = 0; j < c; j++)
{
sum += 5;
if(i < sum)
{
sum -= 5;
break;
}
}
//再判断2
for(j = 0;j < b;j++){
sum += 2;
if(i < sum){
sum -= 2;
break;
}
}
//最后判断1
for(j = 0;j < a;j++){
sum += 1;
if(i < sum){
sum -= 1;
break;
}
}
if(sum < i){
cout << i << endl;
break;
}
}
}
return 0;
}
小结:
本来想的是根据输入建立一个超大的数组,然后把所有可能的情况全都考虑进去,然后数组去重,排序,再对数组扫描,找出不是相邻的数,两者之间最小的数就是答案。
实际敲起来泰国麻烦,重申题意,只要考虑最小的就好了,按照我们处理这种问题的方式,应该不会是上面想的那样,最暴力的方式就是一个一个去试,这是最适合计算机的方式,代码就很简单了。