Holding Bin-Laden Captive!

本文介绍了一道关于使用三种面额硬币(1元、2元、5元)支付任意金额的问题。通过逐个尝试的方法找到无法支付的最小正数值,并提供了一段实现该算法的C++代码。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目来自杭电:http://acm.hdu.edu.cn/showproblem.php?pid=1085
Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17440 Accepted Submission(s): 7814

Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
“Oh, God! How terrible! ”

Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds– 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.

Sample Input
1 1 3
0 0 0

Sample Output
4
代码:

#include <iostream>
#include <fstream>
#include <algorithm>
const int MAX = 1000 + 10;
using namespace std;


int main()
{
    int a,b,c;
    int i,j;
    int sum;

    while(cin >> a >> b >> c)
    {
        if(a == 0 && b == 0 && c == 0)
            break;

        for(i = 1;; i++)
        {
            sum = 0;
            //先判断5
            for(j = 0; j < c; j++)
            {
                sum += 5;
                if(i < sum)
                {
                    sum -= 5;
                    break;
                }
            }

            //再判断2
            for(j = 0;j < b;j++){
                sum += 2;
                if(i < sum){
                    sum -= 2;
                    break;
                }
            }

            //最后判断1
            for(j = 0;j < a;j++){
                sum += 1;
                if(i < sum){
                    sum -= 1;
                    break;
                }
            }

            if(sum < i){
                cout << i << endl;
                break;
            }

        }

    }
    return 0;
}

小结:
本来想的是根据输入建立一个超大的数组,然后把所有可能的情况全都考虑进去,然后数组去重,排序,再对数组扫描,找出不是相邻的数,两者之间最小的数就是答案。
实际敲起来泰国麻烦,重申题意,只要考虑最小的就好了,按照我们处理这种问题的方式,应该不会是上面想的那样,最暴力的方式就是一个一个去试,这是最适合计算机的方式,代码就很简单了。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值