Integer Inquiry

题目来自杭电:http://acm.hdu.edu.cn/showproblem.php?pid=1047
Integer Inquiry
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15361 Accepted Submission(s): 3943

Problem Description

One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
This supercomputer is great,'' remarked Chip.I only wish Timothy were here to see these results.” (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Sample Input

1

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670

代码:

#include <iostream>
#include <cstring>
using namespace std;

int main()
{
    char a[128];
    int sum[128];
    int n;
    int i,j;
    int temp;
    int carry;

    cin >> n;
    while(n--)
    {
        memset(sum,0,sizeof(sum));
        while(cin >> a,strcmp(a,"0"))
        {
            for(i = j = strlen(a) - 1; i >= 0; i--)
                sum[j-i] += a[i] - '0';
        }
        carry = 0;
        for(i = 0; i < 110; i++)
        {
            temp = sum[i] + carry;
            sum[i] = temp % 10;
            carry = temp / 10;
        }
        i = 109;
        while(!sum[i])
            i--;
        if(i < 0)
            cout << "0";
        for(; i >= 0; i--)
            cout << sum[i];
        cout << endl;
        if(n)
            cout << endl;
    }
    return 0;
}

小结:和之前的大数问题相似,解决实现也是一样,用数组来存储,处理时单位相加,然后处理进位问题,记住,每一个这是数组,每一个存储单元可以存储多位数,可以参考之前的大数相乘。
本文是看了别人的博客深受启发,觉得自己写的代码虽然能解决问题,但逻辑不够清楚,
所以这是借鉴的别人的代码
所以这是借鉴的别人的代码
所以这是借鉴的别人的代码
参考链接:http://blog.youkuaiyun.com/lin_miao0818/article/details/2868861

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值