Mayor's posters
Time Limit: 1000MS | Memory Limit: 65536K |
Description
The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.
- Every candidate can place exactly one poster on the wall.
- All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
- The wall is divided into segments and the width of each segment is one byte.
- Each poster must completely cover a contiguous number of wall segments.
They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.
Input
The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l
i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l
i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l
i, l
i+1 ,... , ri.
Output
For each input data set print the number of visible posters after all the posters are placed.
The picture below illustrates the case of the sample input.
The picture below illustrates the case of the sample input.

Sample Input
1 5 1 4 2 6 8 10 3 4 7 10
Sample Output
4
————————————————————集训24.1的分割线————————————————————
前言:被坑死了!!这题数据范围根本不是10000。照两万做才对。
思路:因为给出的区间可能非常非常大,线段树解决不了,所以需要进行离散化处理——
保留能用到的区间,其他区间将被丢弃。
但是可能有的区间会在离散的过程中被忽略:如下:(数据为1-10 1-4 6-10)
用到的区间:【1,4】【5,5】【6,10】
离散之后变成:(1 4 6 10离散成1 2 3 4)
用到的区间:【1,2】【3,4】
这个时候【5,5】就被忽略了。
采用胡大大的技巧,就是在两个差值大于1的数之间人为地添加一个数字,来表示该区间的存在。
用到的区间:【0,1】【2,4】【5,6】【7,10】
注意引进了0,如果没有0的话,就无法处理开头的区间。
完成了离散之后,要实现成段替换。整棵线段树初始化为-1即可。
线段树本身就是懒惰标记。值就代表了该区间共享一个value。
最后查询的时候数线段树有多少种值就行了。
代码如下:
/*
ID: j.sure.1
PROG:
LANG: C++
*/
/****************************************/
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <string>
#include <iostream>
#define INF 0x3f3f3f3f
#define LL long long
using namespace std;
/****************************************/
#define lson l, m, rt<<1
#define rson m+1, r, rt<<1|1
const int maxn = 22222;
int li[maxn], ri[maxn], ans, cnt, _cnt;
int X[maxn*3], lazy[maxn*12];
bool vis[maxn];
void Lisan()
{
sort(X, X+cnt);
_cnt = 1;
for(int i = 1; i < cnt; i++) {
if(X[i] != X[i-1])
X[_cnt++] = X[i];
}//去重
for(int i = _cnt - 1; i > 0; i--) {
if(X[i] - X[i-1] > 1)
X[_cnt++] = X[i-1] + 1;
}//添加点表示被忽略区间的存在
sort(X, X+_cnt);
}
void Down(int rt)
{
if(lazy[rt] != -1) {
lazy[rt<<1] = lazy[rt<<1|1] = lazy[rt];
lazy[rt] = -1;
}
}
void update(int L, int R, int post, int l, int r, int rt)
{
if(L <= l && r <= R) {
lazy[rt] = post;//相当于染色,表示该区间全部都是post
return ;
}
Down(rt);
int m = (l+r)>>1;
if(L <= m) update(L, R, post, lson);
if(m < R) update(L, R, post, rson);
}
void query(int l, int r, int rt)
{
if(lazy[rt] != -1) {
if(!vis[lazy[rt]])
ans++;//数出有几种post
vis[lazy[rt]] = true;
return ;
}
if(l == r) return ;
int m = (l+r) >> 1;
query(lson); query(rson);
}
int main()
{
#ifdef J_Sure
// freopen("000.in", "r", stdin);
// freopen(".out", "w", stdout);
#endif
int T, n;
scanf("%d", &T);
while(T--) {
scanf("%d", &n);
cnt = 0;
for(int i = 0; i < n; i++) {
scanf("%d%d", &li[i], &ri[i]);
X[cnt++] = li[i]; X[cnt++] = ri[i];
}
Lisan();
memset(lazy, -1, sizeof(lazy));
for(int i = 0; i < n; i++) {
int l = lower_bound(X, X+_cnt, li[i]) - X;
int r = lower_bound(X, X+_cnt, ri[i]) - X;
update(l, r, i, 0, _cnt, 1);
}
ans = 0;
memset(vis, false, sizeof(vis));
query(0, _cnt, 1);
printf("%d\n", ans);
}
return 0;
}