Find them, Catch them
Time Limit: 1000MS | Memory Limit: 10000K |
Description
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)
Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:
1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.
2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.
Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:
1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.
2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1 5 5 A 1 2 D 1 2 A 1 2 D 2 4 A 1 4
Sample Output
Not sure yet. In different gangs. In the same gang.————————————————————集训9.2的分割线————————————————————
思路:关系并查集的简单应用。类似于知名题目食物链。要注意的只有两个:
1. 如果仅有两个人,根据题意有两个帮派,那么他们一定是属于不同帮派
2. 已知帮派的人和未知帮派的人分属于两个集合,已知的肯定都属于同一个根,其他的都是自己为根。这是not sure的原因。
代码如下:
/*
ID: j.sure.1
PROG:
LANG: C++
*/
/****************************************/
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <string>
#include <iostream>
#define INF 2e9
using namespace std;
/****************************************/
const int N = 1e5+5;
const int r_sex[][2] = {1, 0, 0, 1}, r_gra[][2] = {0, 1, 1, 0};
int fa[N], rela[N], n, m;
void init()
{
for(int i = 1; i <= n; i++) {
fa[i] = i;
rela[i] = 0;
}
}
int Find(int x)
{
int tmp;
if(x != fa[x]) {
tmp = fa[x];
fa[x] = Find(fa[x]);
rela[x] = r_gra[rela[x]][rela[tmp]];
}
return fa[x];
}
void Union(int x, int y)
{
int fx = Find(x), fy = Find(y);
if(fx != fy) {
fa[fy] = fx;
rela[fy] = r_sex[rela[x]][rela[y]];
return ;
}
}
int main()
{
#ifdef J_Sure
freopen("1703.in", "r", stdin);
// freopen(".out", "w", stdout);
#endif
int T;
scanf("%d", &T);
while(T--) {
scanf("%d%d", &n, &m);
init();//这玩意儿一开始放错位置QAQ
char op[2];
int a, b;
while(m--) {
scanf("%s%d%d", &op, &a, &b);
if(op[0] == 'D')
Union(a, b);
else {
if(n == 2)
puts("In different gangs.");//坑死你
else if(Find(a) != Find(b))
puts("Not sure yet.");
else if(rela[a] == rela[b])
puts("In the same gang.");
else
puts("In different gangs.");
}
}
}
return 0;
}