这几天一直在看王晓东的《计算机算法设计与分析》,不得不承认,受益匪浅!
但是……他能不能不要所有的算法都举一样的例子啊!!脑子不好的人很容易混乱好吗!!
虽然早已经做好了看第二遍第三遍第四遍的准备,但是学时清楚学后混乱的感觉还是很不好啊啊啊啊啊!!!
唉,军校的苦恼,不能从早到晚敲代码了,虽然争分夺秒地看书,但还是感觉生疏了好多……
今天本来上午自习,下午党团活动,可以看一天书的……结果下午拉出去训了一下午队列……尼玛好浪费时间……
于是就这么不淡定的状况下找了一道水题来做,状况百出,泪奔……(被加亮的地方WA一次,汗)
Candy Sharing Game
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 2496 Accepted Submission(s): 1548
Problem Description
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student
simultaneously gives half of his or her candy to the neighbor on the right.
Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.
Input
The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.
Output
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.
Sample Input
6 36 2 2 2 2 2 11 22 20 18 16 14 12 10 8 6 4 2 4 2 4 6 8 0
Sample Output
15 14 17 22 4 8HintThe game ends in a finite number of steps because: 1. The maximum candy count can never increase. 2. The minimum candy count can never decrease. 3. No one with more than the minimum amount will ever decrease to the minimum. 4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.
代码:
#include <iostream>
using namespace std;
bool equal(int a[], int n)
{
for(int i=0; i<n-1; i++)
if(a[i] != a[i+1]) return false;
return true;
}
int main()
{
int N;
while(cin >> N)
{
if(N==0) break;
int *p = new int[N];
int sum=0;
for(int i=0; i<N; i++)
cin >> p[i];
while(equal(p,N)==false)
{
for(i=0; i<N; i++)
p[i]/=2;
int temp=p[N-1];
for(i=N-1; i>0; i--)
p[i]+=p[i-1];
p[0]+=temp;
for(i=0; i<N; i++)
if(p[i]%2==1) p[i]++;
sum++;
}
cout << sum << " " << p[0] << endl;
}
return 0;
}