An easy problem
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 5758 Accepted Submission(s): 1411
Problem Description
When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..
One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :
Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?
Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?

One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :
Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?
Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?
Input
The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10
10).
Output
For each case, output the number of ways in one line.
Sample Input
2 1 3
Sample Output
0 1
i*j+i+j+1=(i+1)(j+1)
#include<stdio.h>
int main()
{
int cas;
__int64 i,n,ans;
scanf("%d",&cas);
while(cas--)
{
scanf("%I64d",&n);
ans=0;
for(i=2; i*i<=n+1; i++)
if((n+1)%i==0) ans++;
printf("%I64d\n",ans);
}
return 0;
}