HDU 1671 字典树

Phone List




Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
  
  
NO YES


这个题目与下面的poj1056是一模一样的..没有什么变化

#include <iostream>
using namespace std;
char s[10001][55];
int vis[10001];
struct node
{
	node *next[26];
	int flag;
	node()
	{
		memset(next,0,sizeof(next));
		flag=0;
	}
};
node *root=NULL;
void build(char *s)
{
	node *p=root;
	int i,len=strlen(s);
	for(i=0;i<len;i++)
	{
		if(p->next[s[i]-'0']==NULL)
			p->next[s[i]-'0']=new node;
		p=p->next[s[i]-'0'];
		p->flag++;
	}
}
int findstr(char *s)
{
	node *p=root;
	int i,len=strlen(s);
	for(i=0;i<len;i++)
	{
		if(p->next[s[i]-'0']!=NULL)
			p=p->next[s[i]-'0'];
		else
			return 0;
	}
	return p->flag;
}
void del(node *p)
{
	for(int i=0;i<10;i++)
		if(p->next[i])
			del(p->next[i]);
	delete p;
}
int main()
{

	int t,n,i;
	char s1[55];
	scanf("%d",&t);
	while(t--)
	{
		root=new node;
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%s",s[i]);
			build(s[i]);
		}
		int judge=0;
		int len,j;
		for(i=0;i<n;i++)
		{
			if(findstr(s[i])>1)
			{
				judge=1;
				break;
			}
		}
		judge==0?cout<<"YES"<<endl:cout<<"NO"<<endl;
		del(root);
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值