Max Sum
Total Submission(s): 115384 Accepted Submission(s): 26761
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
Code:
简单的dp思想,可惜我还是没感觉,觉悟不够。。==
#include<stdio.h>
int a[100005];
int main()
{
int t,i,c,n,maxsum,cursum,begin,end,pos;
scanf("%d",&t);
for(c=1;c<=t;c++)
{
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d",&a[i]);
begin = end = pos = 0;
cursum = maxsum = a[0];
for(i=1;i<n;i++)
{
if(cursum+a[i]<a[i]){
pos = i;
cursum = a[i];
}
else cursum = cursum + a[i];
if(cursum>maxsum){
end = i;
begin = pos;
maxsum = cursum;
}
}
printf("Case %d:\n%d %d %d\n",c,maxsum,begin+1,end+1);
if(c<t) printf("\n");
}
return 0;
}