首字母变大写
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28304 Accepted Submission(s): 15720
Problem Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。
Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
Output
请输出按照要求改写后的英文句子。
Sample Input
i like acm
i want to get an accepted
Sample Output
I Like Acm
I Want To Get An Accepted
算法代码
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
while (scanner.hasNext()) {
String[] str = scanner.nextLine().split("[\\s]");
for (int i = 0; i < str.length; i++) {
char[] chs = str[i].toCharArray();
System.out.print(Character.toUpperCase(chs[0]));
for (int j = 1; j < chs.length; j++) System.out.print(chs[j]);
System.out.printf(i < str.length - 1 ? " " : "\r\n");
}
}
}
}