第几天?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 69781 Accepted Submission(s): 26439
Problem Description
给定一个日期,输出这个日期是该年的第几天。
Input
输入数据有多组,每组占一行,数据格式为YYYY/MM/DD组成,具体参见sample input ,另外,可以向你确保所有的输入数据是合法的。
Output
对于每组输入数据,输出一行,表示该日期是该年的第几天。
Sample Input
1985/1/20
2006/3/12
Sample Output
20
71
分析
判断闰年加1天的时候,还要注意月份是否过了2月。
算法代码
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
int[] month = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30};
Scanner scanner = new Scanner(System.in);
scanner.useDelimiter("[^0-9]");
int y, m, d;
while (scanner.hasNext()) {
y = scanner.nextInt();
m = scanner.nextInt();
d = scanner.nextInt();
scanner.next();
for (int i = 0; i < m; i++) d += month[i];
if (m > 2) d += isLeapYear(y);
System.out.println(d);
}
}
// 闰年判断
public static int isLeapYear(int y) {
if (y % 4 == 0 && (y % 100 != 0 || y % 400 == 0)) return 1;
return 0;
}
}