水数论HDU 2973

YAPTCHA

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 599    Accepted Submission(s): 334


Problem Description
The math department has been having problems lately. Due to immense amount of unsolicited automated programs which were crawling across their pages, they decided to put Yet-Another-Public-Turing-Test-to-Tell-Computers-and-Humans-Apart on their webpages. In short, to get access to their scientific papers, one have to prove yourself eligible and worthy, i.e. solve a mathematic riddle.


However, the test turned out difficult for some math PhD students and even for some professors. Therefore, the math department wants to write a helper program which solves this task (it is not irrational, as they are going to make money on selling the program).

The task that is presented to anyone visiting the start page of the math department is as follows: given a natural n, compute

where [x] denotes the largest integer not greater than x.
 

Input
The first line contains the number of queries t (t <= 10^6). Each query consist of one natural number n (1 <= n <= 10^6).
 

Output
For each n given in the input output the value of Sn.
 

Sample Input
  
  
13 1 2 3 4 5 6 7 8 9 10 100 1000 10000
 

Sample Output
  
  
0 1 1 2 2 2 2 3 3 4 28 207 1609 题意就是叫你求上述那个公式在不同N下的结果。 思路:很显然的将上述式子换下元另p=3k+7则有 Σ【(p-1)!+1/p-[(p-1)!/p]】 接下来用到一个威尔逊定理,如果p为素数则(p-1)!+1=0(modp),因此不难发现【*】里面要么为0,要么为1,为1的情况就是p为素数的情况,然后统计k=1-n中 有多少个3*k+1素数就好了->打一个大一点的素数表,用一个ans数组记录前缀和就行了= =一开始大小了WA了两发ORZZZ。。。然后还有不知道为什么开始素数表都 打错了= = 手生了么= =|||。。。
#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=1000110;
bool is_prime[3*maxn];
int ans[maxn];
int cnt;
void dabiao()
{
    memset(is_prime,0,sizeof(is_prime));
    is_prime[0]=is_prime[1]=1;
    int n=(maxn-10)*3;
    int m=maxn-10;
    for(int i=2;i<=n;i++)
    {
        if(is_prime[i]!=0)
        {
            continue;
        }
        for(int  j=2*i;j<=n;j+=i)
        {
            is_prime[j]=1;
        }
    }

    ans[0]=0;
    for(int i=1;i<=m;i++)
    {
        if(is_prime[3*i+7]==0)
        {
            ans[i]=ans[i-1]+1;
        }
        else
        {
            ans[i]=ans[i-1];
        }
    }

}
int main()
{
    dabiao();

    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        printf("%d\n",ans[n]);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值