2013年山东省赛题目 Alice and Bob

Alice and Bob

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

    Alice and Bob like playing games very much.Today, they introduce a new game.

    There is a polynomial like this: (a0*x^(2^0)+1) * (a1 * x^(2^1)+1)*.......*(an-1 * x^(2^(n-1))+1). Then Alice ask Bob Q questions. In the expansion of the Polynomial, Given an integer P, please tell the coefficient of the x^P.

Can you help Bob answer these questions?

输入

The first line of the input is a number T, which means the number of the test cases.

For each case, the first line contains a number n, then n numbers a0, a1, .... an-1 followed in the next line. In the third line is a number Q, and then following Q numbers P.

1 <= T <= 20

1 <= n <= 50

0 <= ai <= 100

Q <= 1000

0 <= P <= 1234567898765432

输出

For each question of each test case, please output the answer module 2012.

示例输入

122 1234

示例输出

20

提示

The expansion of the (2*x^(2^0) + 1) * (1*x^(2^1) + 1) is 1 + 2*x^1 + 1*x^2 + 2*x^3

来源

 2013年山东省第四届ACM大学生程序设计竞赛

示例程序

 

这个题目其实很水,只需要把这个数的二进制展开,然后对应去乘每一位对应的值就好了


#include<iostream>
#include<cstdio>
#include<cstring>
#include<stack>
using namespace std;
int a[70];
int b[70];

int main()
{
    int i,j,k,q,n;
    long long p;
    int T;
    scanf("%d",&T);
    while(T--)
    {

     scanf("%d",&n);
     memset(a,0,sizeof(a));//很重要
     for(i=0;i<n;i++)
     {
         scanf("%d",&a[i]);
     }
     scanf("%d",&q);
     int na=0;
     int nb=0;
     while(q--)
     {
         scanf("%lld",&p);
         if(p==0)
         {
             printf("1\n");
             continue;

         }
         na=0;
         nb=1;
         while(p)
         {
             b[na]=p%2;
             na++;
             p=p/2;

         }
         /*for(i=0;i<na;i++)
         {
             printf("bb  %d\n",b[i]);
         }*/
         for(i=0;i<na;i++)
         {
            if(b[i])
            {
                nb=nb*a[i]%2012;

            }
         }




       printf("%d\n",nb);



     }


    }
    return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值