hdoj 1018 Big number 求n阶乘的位数

本文探讨了如何高效地计算大整数阶乘的位数,并提供了使用对数转换来简化乘法问题的方法。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24102    Accepted Submission(s): 10939


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
  
  
2 10 20
 

Sample Output
  
  
7 19
 

题意:      求n阶乘的位数    (n可以是很大的数)

思路:    1、将很多大整数的乘法问题转换为加法。         使用取对数的方法。            

                 2、某数取以十为底的对数,所得的数的整数位+1就是这个数的位数。


代码:

#include <iostream>
#include <math.h>


using namespace std;


int main()
{
    long long t,n;
    double i;
    long long m;
    double s;
    cin>>t;
    while(t--)
    {
        s=0;
        cin>>n;
        for(i=1.0;i<=n;i++)
        {
            s+=log10(i);
        }
        m=(long long)s;
        cout<<m+1<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值