Roadblocks
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 6090 | Accepted: 2290 |
Description
Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.
The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersectionN.
The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).
Input
Lines 2.. R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output
Sample Input
4 4 1 2 100 2 4 200 2 3 250 3 4 100
Sample Output
450
Hint
Source
【题目大意】:
在一个图上有许多个农场,有个人从1农场出发,到他的朋友n农场去,他不想走一条最短路径,这次他想换条路走,要你帮他找一条次短路径,次短路的定义是,比最短路径长度短(可能有多条),但是不会比其他的路径长度长。而且告诉你数据中一定存在至少一条次短路。
【分析】:
A*算法+最短路,同POJ 2449,只不过该题为求次短路,即K=2,详情点击:http://blog.youkuaiyun.com/csyzcyj/article/details/17332611<POJ 2449 Remmarguts' Date 求K短路 >
【代码】:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<vector>
#include<stack>
#include<queue>
using namespace std;
#define IMAX 21474836
#define MAXE 200001
#define MAXN 5001
#define MAXQ 100001
struct EDGE{int t,next,v;};
struct STATE
{
int real,est,node;
/*friend bool operator <(STATE X,STATE Y)
{
return X.real+X.est<Y.real+Y.est;
}*/
bool operator <(STATE X)const
{
return X.real+X.est<real+est;
}
};
EDGE a[MAXE];
int N,M,tot=0,last[MAXN],H[MAXN],num[MAXN];
int Q[MAXQ],ans=0;
bool vis[MAXN];
void add(int from,int to,int value)
{
a[++tot].t=to;
a[tot].v=value;
a[tot].next=last[from];
last[from]=tot;
a[++tot].t=from;
a[tot].v=value;
a[tot].next=last[to];
last[to]=tot;
}
void pre_spfa()
{
int right=1;
for(int i=1;i<=N;i++)
H[i]=IMAX;
H[N]=0;
vis[N]=true;
Q[right]=N;
for(int i=1;i<=right;i++)
{
int now=Q[i];
for(int j=last[now];j;j=a[j].next)
{
int to=a[j].t;
if(H[now]+a[j].v<H[to])
{
H[to]=H[now]+a[j].v;
if(!vis[to])
{
vis[to]=true;
Q[++right]=to;
}
}
}
vis[now]=false;
}
}
STATE make(int real,int est,int node)
{
STATE use;
use.real=real;
use.est=est;
use.node=node;
return use;
}
priority_queue<STATE> heap;
void Astar()
{
heap.push(make(0,H[1],1));
while(!heap.empty())
{
STATE now=heap.top();
heap.pop();
num[now.node]++;
if(num[now.node]>2) continue;
if(num[N]==2)
{
ans=now.real;
return;
}
for(int i=last[now.node];i;i=a[i].next)
{
int to=a[i].t;
heap.push(make(now.real+a[i].v,H[to],to));
}
}
}
int main()
{
//freopen("input.in","r",stdin);
//freopen("output.out","w",stdout);
scanf("%d%d",&N,&M);
for(int i=1;i<=M;i++)
{
int A,B,C;
scanf("%d%d%d",&A,&B,&C);
add(A,B,C);
}
pre_spfa();
Astar();
printf("%d\n",ans);
//system("pause");
return 0;
}