uva 10420 List of Conquests(检索+排序)

该博客讲述了如何解决UVA 10420编程问题,该问题涉及对Don Giovanni征服的女性按国家进行计数和排序。输入包括多个国家和女性名字,输出需按国家字母顺序显示每个国家的女性数量。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

List of Conquests
Input: 
standard input
Output: 
standard output
Time Limit: 
2 seconds

In Act I, Leporello is telling Donna Elvira about his master's long list of conquests:

``This is the list of the beauties my master has loved, a list I've made out myself: take a look, read it with me. In Italy six hundred and forty, in Germany two hundred and thirty-one, a hundred in France, ninety-one in Turkey; but in Spain already a thousand and three! Among them are country girls, waiting-maids, city beauties; there are countesses, baronesses, marchionesses, princesses: women of every rank, of every size, of every age.'' (Madamina, il catalogo è questo)

As Leporello records all the ``beauties'' Don Giovanni ``loved'' in chronological order, it is very troublesome for him to present his master's conquest to others because he needs to count the number of ``beauties'' by their nationality each time. You are to help Leporello to count.

Input

The input consists of at most 2000 lines, but the first. The first line contains a number n, indicating that there will be n more lines. Each following line, with at most 75 characters, contains a country (the first word) and the name of a woman (the rest of the words in the line) Giovanni loved. You may assume that the name of all countries consist of only one word.

Output

The output consists of lines in alphabetical order. Each line starts with the name of a country, followed by the total number of women Giovanni loved in that country, separated by a space.

Sample Input

3
Spain Donna Elvira
England Jane Doe
Spain Donna Anna

Sample Output

England 1

Spain 2

题目大意:给出n条语句,第一个单词为国家名2, 后面跟着一个女人的名字,表示这个女人属于这个国家,随后输出每个国家所拥有的女人数(按国家名的字典序)

解题思路:其实只要记录国家名出现的个数就可以了。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define MAX 2005
#define N 205
#define M 80

struct country{
	char city[M];
	char women[N][M];
	int cnt;
	country(){
		memset(city, 0, sizeof(city));
		memset(women, 0, sizeof(women));
		cnt = 0;
	}
};

int cmp(const country &a, const country &b){
	return strcmp(a.city, b.city) < 0;
}

country man[MAX];
int main(){
	int n, leap = 0, bo;
	char str[N], name[M];

	// Read.
	scanf("%d", &n);
	for (int i = 0; i < n; i++){
		bo = 0;
		scanf("%s", man[leap].city);
		gets(man[leap].women[man[leap].cnt++]);

		for (int j = 0; j < leap; j++){
			if (strcmp(man[leap].city, man[j].city) == 0){
				bo = 1;
				strcpy(man[j].women[man[j].cnt++], man[leap].women[man[leap].cnt - 1]);
				break;
			}
		}
		if (bo)
			man[leap].cnt = 0;
		else
			leap++;
	}

	sort(man, man + leap, cmp);	

	for (int i = 0; i < leap; i++)
		printf("%s %d\n", man[i].city, man[i].cnt);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值