Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2 1 2 112233445566778899 998877665544332211
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
第一次用java做题,没什么特别要说的,就是两个大数的相加求和,用java的BigInteger就行了,输入用cin.nextBigInteger(),输出没啥特别的,加法用a.add(b),这道题格式控制比较麻烦而已
import java.io.*;
import java.util.*;
import java.math.*;
public class Main
{
public static void main(String[] args)
{
Scanner cin = new Scanner(new BufferedInputStream(System.in));
BigInteger a,b,c;
int num;
num=cin.nextInt();
for(int i=1;i<=num;++i)
{
a=cin.nextBigInteger();
b=cin.nextBigInteger();
c=(a.add(b));
System.out.print("Case ");
System.out.print(i);
System.out.println(":");
System.out.print(a);
System.out.print(" + ");
System.out.print(b);
System.out.print(" = ");
System.out.println(c);
if(i!=num)
System.out.println();
}
}
}