UVa-674 - Coin Change 不同面值找零的方案数

674 - Coin Change

Time limit: 3.000 seconds



Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.


For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.


Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

Input 

The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output 

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input 

11
26

Sample Output 

4
13

问题的意思是说现在有五种硬币,面值分别是1分、5分、10分、25分、50分,每种硬币的数量不限

要求你对每次给定的一个数值N,求解用这五种面值的硬币凑出N分钱有多少种不同的方案;


本题类似背包问题,可以用滚动数组的动态规划填表法解决,但具体解决方法略有不同,

首先创建一个数组coin,用来存储每种硬币的面值,方便在循环中调用

再创建一个数组'need',用以存储不同的N时的解,并对这个'need'数组进行初始化,

初始化时有些需要注意的问题,要将除need[0]以外的元素全部置为'0',而need[0]则应该为'1'。因为初始状态的实际意义即代表“没有任何硬币时的解”,所以当N=0时,有一种解决方案,即什么硬币都不用即可;而当N!=0时,无论如何都无法找出N分钱,所以解决方案数应该为'0'.

初始条件设置好后,即可开始填表,注意每种硬币可以无限使用,所以滚动数组应从前往后,对于第i种硬币来说,当N=j时,可行的方案数即应该有need[j]+need[j-coin[i]]种,即代表“使用”和“不使用”该硬币时的方案数之和

最后是具体代码

#include<cstdio>
#include<cstring>
int main()
{
	const int coin[]={0,50,25,10,5,1};
	int need[7500],n;
	
	memset(need,0,sizeof(need));
	need[0]=1;

	for(int i=1;i<=5;++i)
	{
		for(int j=coin[i];j<=7500;++j)
		{
			need[j]+=need[j-coin[i]];
		}
	}
	while(scanf("%d",&n)!=EOF)
	{
		printf("%d\n",need[n]);
	}
	return 0;
}


  Coin Change 

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.


For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.


Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

Input 

The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output 

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input 

11
26

Sample Output 

4
13
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值