HDU 4355 Party All the Time (三分水题。。。留着TLE)

本文介绍了HDU 4355 Party All the Time的问题,这是一个关于算法和编程的挑战,通常被归类为简单的题目,适合初学者练习,但需要注意避免超时错误(TLE)。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >


HDU 4355 Party All the Time

Party All the Time

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2400    Accepted Submission(s): 803


Problem Description
In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S 3*W units if it walks a distance of S kilometers. 
Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.
 

Input
The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x [i]<=x [i+1] for all i(1<=i<N). The i-th line contains two real number : X i,W i, representing the location and the weight of the i-th spirit. ( |x i|<=10 6, 0<w i<15 )
 

Output
For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.
 

Sample Input
  
  
1 4 0.6 5 3.9 10 5.1 7 8.4 10
 

Sample Output
  
  
Case #1: 832
 


#pragma comment(linker, "/STACK:102400000,102400000")
#include "iostream"
#include "cstring"
#include "algorithm"
#include "cmath"
#include "cstdio"
#include "sstream"
#include "queue"
#include "vector"
#include "string"
#include "stack"
#include "cstdlib"
#include "deque"
#include "fstream"
#include "map"
using namespace std;
typedef long long LL;
const int INF = 0x1fffffff;
const int MAXN = 1000000+100;
#define eps 1e-14
const int mod = 100000007;

int n;
double rst;

struct node
{
    double pos;
    double weight;
}spirit[50000+100];

double cal(double pos)
{
    double sum=0;
    for (int i=0;i<n;i++)
    sum+=pow(fabs(pos-spirit[i].pos),3)*spirit[i].weight;
    return sum;
}
int main()
{
    //freopen("in","r",stdin);
    int t;
    scanf("%d",&t);
    for (int kase=1;kase<=t;kase++)
    {
        scanf("%d",&n);
        int cnt=0;
        double l,r;
        for (int i=0;i<n;i++)
        {

            scanf("%lf%lf",&spirit[i].pos,&spirit[i].weight);
            l=min(l,spirit[i].pos);
            r=max(r,spirit[i].pos);
        }
        do
        {
            double m=(l+r)/2.0;//三分
            double mm=(m+r)/2.0;
            rst=cal(m);
            if (rst<cal(mm)) r=mm;
            else l=m;
        }while (cnt++<100);//据说比赛要用这个跳出
         printf("Case #%d: %.0lf\n" ,kase,rst);
    }
  return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值