背包(2)poj1276 Cash Machine(多重背包)

本文介绍了一种针对自动取款机的现金提取算法,该算法能在给定的纸币种类及数量限制下,计算出能提供的最大金额,不超过用户请求的现金数额。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Cash Machine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 22943 Accepted: 8038

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

Source

 
 
/*
题意:给你几种面额的钱币和数量,和一个标准cash,问你用所给的钱币,能够得到小于等于cash值的最大值。	明显的多重背包。
方法:将多重背包化为01背包,可以另开一个数组存每种钱币的个数,在做01背包时多加一个条件就行了。
	还可以用二进制方法,把数目用二进制进行分解,比如5个物品,分为1个,2个和2个,用这三个新的物品可以通过01背包的方式重新组合成1,2,3,4,5个物品的情况;
	7个物品可以分为1个,2个和4个……
*/
/* 法一:记录每种钱币的个数 1472K 16MS */
#include <iostream>
#include <cstdio>
#include <string.h>
#include <algorithm>
using namespace std;
int val[11],num[11];
int ans[100005];
int h[100005];
int main()
{
	int n,cash,a;
	while(scanf("%d%d",&cash,&n) != EOF)
	{
		for(int i=1; i<=n; i++)
			scanf("%d%d", &num[i], &val[i]);
		if(cash == 0 || n == 0)
		a = 0;
		else{
		memset(ans, 0, sizeof(ans));
		for(int i=1; i<=n; i++)
		{
			memset(h, 0, sizeof(h));
			for(int j=1; j<=cash; j++)
			{
				if(j - val[i] >= 0 && h[j - val[i]] < num[i] && ans[j] < ans[j-val[i]] + val[i])
				{
					ans[j] = ans[j-val[i]] + val[i];
					h[j] = h[j-val[i]] + 1;
				}
			}
		}
		a = ans[cash];
		}
		printf("%d\n",a);
	}
	return 0;
}
/* 法二:二进制处理 776K 63MS */
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int c[200];
int ans[100005];
int main()
{
	int cash,N,n,d,k;
	while(~scanf("%d%d",&cash,&N))
	{
		memset(c,0,sizeof(c));
		k = 0;
		for (int i = 0; i < N; i++)
		{
			scanf("%d%d",&n,&d);
			if(n==0 || d==0)	continue;
			int x = 1,tem = n,sum = 0;
			while(n>1)
			{
				c[k++] = x*d;
				sum += x;
				n/=2;	x*=2;
			}
			if(tem>sum)
			c[k++] = (tem-sum)*d;			
		}
		memset(ans,0,sizeof(ans));
		for (int i = 0; i < k; i++)
		{
 			for (int j = cash; j >=c[i] ; j--)
			{
				ans[j] = max(ans[j],ans[j-c[i]]+c[i]);
			}
		}
		printf("%d\n",ans[cash]);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值