So Easy!
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 133 Accepted Submission(s): 43
Problem Description
A sequence S
n
is defined as:
Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate S n.
You, a top coder, say: So easy!

Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate S n.
You, a top coder, say: So easy!

Input
There are several test cases, each test case in one line contains four positive integers: a, b, n, m. Where 0< a, m < 2
15, (a-1)
2< b < a
2, 0 < b, n < 2
31.The input will finish with the end of file.
Output
For each the case, output an integer S
n.
Sample Input
2 3 1 2013 2 3 2 2013 2 2 1 2013
Sample Output
4 14 4
Source
Recommend
zhoujiaqi2010
#include <stdio.h>
void mmul(int a[2][2],int b[2][2],int c[2][2],int m)
{
int d[2][2],i,j,k;
for(i=0;i<2;++i)
for(j=0;j<2;++j)
for(k=d[i][j]=0;k<2;++k)
d[i][j]=(d[i][j]+((a[i][k]*b[k][j])%m))%m;
for(i=0;i<2;++i)
for(j=0;j<2;++j)c[i][j]=d[i][j];
}
void mpow(int a[2][2],int b,int c[2][2],int m)
{
int t[2][2],d[2][2],i,j;
for(i=0;i<2;++i)
for(j=0;j<2;++j)
{
d[i][j]=a[i][j]%m;
t[i][j]=i==j?1:0;
}
while(b)
{
if(b&1)
mmul(t,d,t,m);
mmul(d,d,d,m);
b>>=1;
}
for(i=0;i<2;++i)
for(j=0;j<2;++j)
c[i][j]=t[i][j];
}
int main()
{
//freopen("easy.in", "r", stdin);
//freopen("testeasy.out", "w", stdout);
int a,b,m,n,c[2][2],r,i,j;
while(scanf("%d%d%d%d",&a,&b,&n,&m)!=EOF)
{
c[1][0]=1;
c[1][1]=0;
c[0][0]=(a<<1)%m;
c[0][1]=(b-((a*a)%m))%m;
mpow(c,n-1,c,m);
r=(((((((c[0][0]*2)%m)*a)%m)+(c[0][1]*2)%m)%m)+m)%m;
printf("%d\n",r);
}
return 0;
}