Sliding Window
Time Limit: 12000MS | Memory Limit: 65536K | |
Case Time Limit: 5000MS |
Description
An array of size
n ≤ 10
6 is given to you. There is a sliding window of size
k which is moving from the very left of the array to the very right. You can only see the
k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position | Minimum value | Maximum value |
---|---|---|
[1 3 -1] -3 5 3 6 7 | -1 | 3 |
1 [3 -1 -3] 5 3 6 7 | -3 | 3 |
1 3 [-1 -3 5] 3 6 7 | -3 | 5 |
1 3 -1 [-3 5 3] 6 7 | -3 | 5 |
1 3 -1 -3 [5 3 6] 7 | 3 | 6 |
1 3 -1 -3 5 [3 6 7] | 3 | 7 |
Your task is to determine the maximum and minimum values in the sliding window at each position.
Input
The input consists of two lines. The first line contains two integers
n and
k which are the lengths of the array and the sliding window. There are
n integers in the second line.
Output
There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.
Sample Input
8 3 1 3 -1 -3 5 3 6 7
Sample Output
-1 -3 -3 -3 3 3 3 3 5 5 6 7
Source
POJ Monthly--2006.04.28, Ikki
用队列的形式做滑动窗口,保证队列一直是保证单调递减的,这样队头的元素就是最大的元素了,另外也要保证一个元素最多在队列里存在时间不超过窗长度。
贴一个以前的代码(很朴素的呃):
#include<stdio.h>
#include<string.h>
#define MAX 1000000+10
struct queue
{
int num,p;
}a[MAX];
int b[MAX];
int n,k,front ,rear;
void Queuemin(int t)
{
while(a[rear].num>=b[t] && rear>=front)rear--;
rear ++;
a[rear].p = t;
a[rear].num = b[t];
}
void Queuemax(int t)
{
while(a[rear].num<=b[t] && rear>=front)rear--;
rear ++;
a[rear].p = t;
a[rear].num = b[t];
}
int main()
{
int i,j,t;
scanf("%d %d",&n,&k);
for(i = 1;i <= n;i++)
{
scanf("%d",&b[i]);
}
front = 1;
rear = 0;
for(j = 1;j<=k-1 && j<=n;j++)
{
Queuemin(j);
}
for(int i = k;i<=n;i++)
{
while(front<=rear && a[rear].num>=b[i])rear--;
rear++;
a[rear].p = i;
a[rear].num = b[i];
while(a[front].p<=i-k)front++;
printf("%d ",a[front].num);
}
printf("\n");
memset(a,'\0',sizeof(a));
front = 1;
rear = 0;
for(j = 1;j<=k-1 && j<=n;j++)
{
Queuemax(j);
}
for(int i = k;i<=n;i++)
{
while(front<=rear && a[rear].num<=b[i])rear--;
rear++;
a[rear].p = i;
a[rear].num = b[i];
while(a[front].p<=i-k)front++;
printf("%d ",a[front].num);
}
printf("\n");
return 0;
}
待会再写一个用queue写的吧,待会再发。。。嘿!