1004. Counting Leaves (30)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.
Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output “0 1” in a line.

Sample Input
2 1
01 1 02
Sample Output
0 1
这道题就是bfs遍历树,使用邻接矩阵存储树,然后用bfs遍历,但是要输出每层的叶子节点,那就需要分别出每层,那么在队列中的每层节点之间加入一个0来分辨不同层即可。这个方法也是从别人博客上看到的,觉得很巧妙,就搬过来了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>


using namespace std;
#define M 101
int map[M][M];
queue<int> que;

int n, m;

int bfs_level(int s){
    int flag = 1;
    for (int i = 1; i <=n; i++){
        if (map[s][i] == 1){
            que.push(i);
            flag = 0;
        }
    }
    return flag;
}

void bfs(){
    que.push(1);
    que.push(0);
    int cnt = 0;
    while (!que.empty()){
        int s = que.front();
        que.pop();
        if (s == 0){
            if (que.empty()){
                cout<<cnt<<endl;
                break;
            }
            else{
                que.push(0);
                cout << cnt << " ";
                cnt = 0;
            }
        }
        else{
            int flag = bfs_level(s);
            cnt += flag;
        }
    }

}
int main()
{
    cin >> n >> m;
    memset(map, 0, sizeof(map));
    for (int i = 0; i < m; i++){
        int id, k;
        cin >> id >> k;
        for (int j = 0; j < k; j++){
            int chi;
            cin >> chi;
            map[id][chi] = 1;
        }
    }
    bfs();
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值