传送门:Ultra-QuickSort
Ultra-QuickSort
Time Limit: 7000MS | Memory Limit: 65536K | |
Total Submissions: 37112 | Accepted: 13350 |
Description

Ultra-QuickSort produces the output
Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input
5 9 1 0 5 4 3 1 2 3 0
Sample Output
6 0
Source
解题报告:
这题用树状数组,需要离散化才行。。
离散化的步骤就是, 先用一个结构体,用num 保存 原来的数,id保存原来数组所在的位置。。然后按num排序,那么得到一个从小到大有序的序列。 然后通过id找到原数组所在的位置,并用另一个数组存放 通过映射得到的新的类似原来序列的数组。
代码如下:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 500010
using namespace std;
struct node{
int num,id;
}s[maxn];
int ans[maxn],result[maxn];
bool cmp(const node &a,const node &b){
return a.num<b.num;
}
int lowbit(int n){ //lowbit
return n & (-n);
}
void modify(int x){ //修改modify
for(int i = x; i<maxn; i+=lowbit(i))
ans[i]++;
}
int getSum(int x){ //求和sum
long long sum= 0;
for (int i = x; i > 0; i -= lowbit(i))
sum += ans[i];
return sum;
}
int main(){
int n;
while(scanf("%d",&n)==1&&n){
memset(ans,0,sizeof(ans));
for(int i=1;i<=n;i++){
scanf("%d",&s[i].num);
s[i].id=i;
}
sort(s+1,s+n+1,cmp);
result[s[1].id]=1;
for(int i=2;i<=n;i++){
if(s[i].num==s[i-1].num)
result[s[i].id]=result[s[i-1].id];
else
result[s[i].id]=i;
}
long long sum=0;
for(int i=n;i>=1;i--){
sum+=getSum(result[i]-1);
modify(result[i]);
}
printf("%lld\n",sum);
}
return 0;
}