传送门:Relatives
Relatives
Source : Waterloo ACM Programming Contest June 1, 2002 | |||
Time limit : 1 sec | Memory limit : 32 M |
Submitted : 536, Accepted : 226

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.
Input
There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.
Output
For each test case there should be single line of output answering the question posed above.
Sample Input
7 12 0Sample Output
6 4
解题报告:
此题为欧拉函数模板题,代码如下:
#include<iostream>
#include<cstdio>
using namespace std;
int eular(int n){
int ret=1,i;
for(i=2;i*i<=n;i++)
if (n%i==0){
n/=i,ret*=i-1;
while (n%i==0)
n/=i,ret*=i;
}
if (n>1)
ret*=n-1;
return ret; //n的欧拉数
}
int main(){
int n;
while(scanf("%d",&n)&&n){
printf("%d\n",eular(n));
}
return 0;
}