How Many Fibs_hdu_1316(大数).java

本文介绍了一种方法来计算给定范围内的斐波那契数的数量,包括输入样例和代码实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3098    Accepted Submission(s): 1232


Problem Description
Recall the definition of the Fibonacci numbers: 
f1 := 1 
f2 := 2 
fn := fn-1 + fn-2 (n >= 3) 

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b]. 
 

Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
 

Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b. 
 

Sample Input
  
  
10 100 1234567890 9876543210 0 0
 

Sample Output
  
  
5 4
 


import java.math.BigInteger;
import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		Scanner input=new Scanner(System.in);
		BigInteger f[]=new BigInteger[505];
		f[0]=BigInteger.valueOf(1);
		f[1]=BigInteger.valueOf(2);
		for(int i=2;i<502;i++){
			f[i]=f[i-1].add(f[i-2]);
		}
		while(true){
			BigInteger a=input.nextBigInteger();
			BigInteger b=input.nextBigInteger();
			if(a.equals(BigInteger.ZERO)&&b.equals(BigInteger.ZERO))
				break;
			int sum=0;
			for(int i=0;i<502&&b.compareTo(f[i])>=0;i++){
				if(f[i].compareTo(a)>=0)
					sum++;
			}
			System.out.println(sum);
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值